0

after doing a clean install of Elementary OS, i got the Grub boot loader. So i thought, i get rid of the whole installation and do a full clean reinstall. And now i have a double Grub boot loader. On the first Grub i get the selection of 1. ubuntu 2. Drive 0: Samsung SSD drive ...

On this first menu i have to select option 2 (Samsung SSD drive) Then i get the 2nd Grub menu: 1. ubuntu 2. Drive 0: Samsung SSD drive ... Exactly the same menu, and here if have to do ESC to boot ElementaryOS

This is no multiboot pc, no Windows or any other distro's, so i don't get why i end up with the Grub menu anyway.

So now the question is: how to get rid of Grub all together and boot into ElementaryOS straight away? need to select my SSD harddrive.

0

This is really strange since it means you have two /boot partitions.

Can you show the output of

fdisk -l

As a work around, if you do not want to try another reinstall, you can set your preferred option in both grub menus to the first place (as default option) and set the menu timeout to 0.

  • hi, i got following message: WARNING: GPT (GUID Partition Table) detected on '/dev/sda'. So i ran "parted -l'. The output is: Model: ATA Samsung SSD 840 (scsi) Disk /dev/sda: 250GB Sector size (logical/physical): 512B/512B Partition Table: gpt Number Start End Size File system Name Flags 1 1049kB 538MB 537MB fat32 boot 2 538MB 246GB 245GB ext4 3 246GB 250GB 4176MB linux-swap(v1) – Dirk Sep 1 '16 at 21:43
0

Partitioning seems fine. My take is that you're actually seeing the UEFI boot menu at startup. Access yor BIOS settings before boot and edit those entries. I usually delete everything in there and create a new "elementary" entry pointing to, in my case, HHD0\EFI\ubuntu\grubx64.efi Save and reboot. Go back to BIOS and set this newly created entry as first in the boot menu.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.