I used to have my main disk with Elementary have Windows 10 (which is on a separate SSD) as an option on GRUB on Loki. I have just updated to Juno, but now I can't seem to add Windows 10 to the boot options. Windows still boots if I select windows boot manger from the BIOS settings.

I have tried using os-prober and update-grub, which is how I added them on Loki.


1 Answer 1


try boot repair from this ppa: Boot-Repair

  • Thanks for your reply. "The current session is in Legacy mode. Please reboot the computer, and use this software in an EFI session. This will enable this feature. For example, use a live-USB of Boot-Repair-Disk-64bit (www.sourceforge.net/p/boot-repair-cd), after making sure your BIOS is set up to boot USB in EFI mode." Is what I get when I run the repair. Is that correct, should Elementary be installed with legacy BIOS? Or is there something else I should be running on the program?
    – psy_blades
    Commented Nov 2, 2018 at 19:58
  • then try boot from live USB (eOS or ubuntu), EFI mode. 1. add the boot-repair ppa 2.update 3.install boot-repair 4.repair. i did that a few times.
    – user6308
    Commented Nov 5, 2018 at 1:56
  • Please note that for EFI boot, Linux Mint ISO does include boot-repair from scratch, so you don't have to install everything, just run it in EFI boot mode. It would be great that both Elementary and Ubuntu include this tool in the base ISO. I have had instances where I could not install boot-repair from boot, so in case that solves it.
    – Lurch
    Commented Oct 20, 2019 at 2:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.