0

I've been grappling with installing some Ubuntu packages with apt-get so I thought I'd post an example for anyone else struggling with Elementary OS. Here libssl or openssl won't install and these are dependencies I need for R packages. I suspect this is because I have added Ubuntu PPA's and updated already.

Note that reinstalling with apt-get remove or apt-get install -f does not resolve this.

ssl_question

1

This can be resolved by installing aptitude with:

sudo apt-get install aptitude

Then running

sudo aptitude install libssl-dev

and selecting the options as follows.

ssl_answer

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.