1

I love the look of elementary, but have encountered a frustrating problem.

The trackpad was working when I selected the "try" option from the boot menu, but doesn't work now that I've installed the OS (I don't imagine it matters, but I selected the default "erase disc and install" option).

EDIT 1 OK, the problem is actually much bigger than just the trackpad not working - a whole bunch of hardware has not been detected, see screenshot of my system settings, there is no audio option, no trackpad listed, no bluetooth:

system settings

Any ideas??

EDIT 2 Very weird, the trackpad problem remained through numerous reboots. I installed another Linux (Sabyon/Gentoo, not that it should matter), which detected and enabled the trackpad without issue (but had plenty of other problems!) and now, I've rebooted to Elementary, and the trackpad is working!?

Honestly, it's things like this that I end up back on Windows over the last 10 years or so :(

EDIT 3 It's very odd, the trackpad sometimes works after reboot, and sometimes not. I cannot determine any pattern to explain why it does or doesn't work at any particular time. The 'soft' buttons are never finctional, nor is there ever a "Mouse/Trackpad" option in the system settings

  • 1
    Ok, for starters, edit the question to reflect one problem. Open other questions to different problems. – lf_araujo Nov 29 '15 at 4:16
  • Your definition of 'help' obviously differs from mine – emjaySX Nov 29 '15 at 9:08
  • 1
    Ok. I made that comment because it is not clear whether you solved the trackpad issue. If it is the case, what is the next issue to approach? The bluetooth or the audio settings? So, if you split these issues into different questions you will make it easy for people to help you. – lf_araujo Nov 29 '15 at 9:15
  • May I ask which exact model of HP laptop are you using? You said that everything worked on live USB boot? – BoA Nov 29 '15 at 16:59
  • Trackpad issue has not been resolved, nor have any of the other issues, but the trackpad is the biggest problem, the others are just annoyances, at this stage – emjaySX Nov 29 '15 at 20:31
3

Missing panels in Switchboard doesn't really have anything to do with hardware. Most likely, you've installed some third party software, possibly from a third party PPA that conflicts with Switchboard.

You'll need to reinstall the missing switchboard-plug-gcc-* packages from Terminal. For example, for sound:

sudo apt install switchboard-plug-gcc-sound

You can use tab to auto-complete in Terminal to discover the names of other plugs to install.

  • The trackpad worked in the live environment, but not upon booting from the harddrive installation. The touchpad began working in Elementary only after I installed another Linux installation, but this was most likely coincidental, as it has since stop working and started working again after various reboots with no pattern I can discern. Blaming the user is a poor attitude to take – emjaySX Nov 30 '15 at 1:47
0

Try updating kernel to 4.1 or above. It fixed my problem with alps touchpad in my Pavilion 14.

Here=>Ubuntu kernel repository

You should download 3 packages, linux-headers***all.deb, linux-headers***$ARCH.deb, linux-image***$ARCH.deb, $ARCH is i386 for 32 bits systems or amd64 for 64 bits systems. "generic" packages are for standard kernel, "lowlatency" are (obviously)for lowlatency kernel. After download install using your favorite method, from terminal

cd /download/path
sudo dpkg -i linux*.deb
  • Well, I gave this a go, but no joy. Which I expected, to be honest, updating the kernel was never going to make the mouse/trackpad options appear in 'system settings' – emjaySX Nov 29 '15 at 5:09
0

I'd recommend first trying to update your system with the latest elementary OS updates, with any luck, that might fix your problem.

If not, try going to the HP drivers page for your laptop, seeing what general type of drivers they are (i.e. synaptics for touchpads), then installing that on your system and hopefully your devices will be detected now.

Warning, I'm completely new to linux and this may break things - this is all conjecture from my own experience with similar problems

  • Yeah, I updated the system immediately after installation yesterday. Trackpad is working, now, for no apparent reason, but I'm still missing all the hardware settings options – emjaySX Nov 27 '15 at 23:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.