3

I installed elementary OS Freya 0.3.2 on my ASUS X200MA, run all the updates. I wanted to activate two-finger scroll, ticked the option in the mouse and trackpad system settings. But it doesn't work. I re-entered the system settings, and it doesn't save the option that I'd ticked.

Is it a kernel problem, or a problem derived from its 14.04 Ubuntu base? Because the two finger-scroll is working well in, let's say, Ubuntu 15.10 and all its derivatives.

2

If you use synaptics driver you will probably have the synclient program installed. In terminal have a look at your current touchpad settings:

$ synclient -l | sort (Of course it will show the settings without the "sort" - but it is much easier to find settings when they are listed in alphabetically order)

You will get a list with many settings. We are interested in the option "VertTwoFingerScroll". If the output is "VertTwoFingerScroll = 0" the option is disabled. To enable try

$ synclient VertTwoFingerScroll=1

Hope this helps.

  • I followed your instruction and found out that I didn't have my synaptics driver installed. Then I stumbled upon this elementaryos.stackexchange.com/questions/821/… , and now my touchpad works like a charm. It's said that my laptop use elantech driver, and this problem is solved out of the box in 4.x kernel. So it's considered solved, then. – Bagus Farisa Feb 7 '16 at 1:21
0

go to system settings and enable multi touch along with two finger scrolling . then it should work fine. i am using asus ux305

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.