1

I was updating my system today and it keeps refusing to install the new operating system updates. I even reinstalled my operating system and it still refuses to load. Here is what the Error is:

The following packages have unmet dependencies: libpantheon-files-core0: Conflicts: libpantheon-files-widgets0 (< 6.1.1) but 6.1.0+r5055+pkg107~ubuntu6.1 is to be installed .

Does anyone know how to fix this?

5
  • Are you trying to upgrade from Hera to Odin? 🤔
    – matigo
    Dec 14, 2021 at 14:51
  • Odin was installed both times Dec 14, 2021 at 14:52
  • Do you see an additional message like "You might want to run apt --fix-broken install"? It's not often that core Pantheon files fall out of sync with each other ...
    – matigo
    Dec 14, 2021 at 15:02
  • I did not. Now it just worked and i did nothing different so I have no clue what fixed it. Dec 14, 2021 at 15:16
  • While the error may be disregarded, the system stops upgrading from 6.0 to 6.1. Anyone care to tell how to bypass this? Thank you
    – Brian T.
    Dec 22, 2021 at 4:50

2 Answers 2

0

The error can be disregarded because it is harmless according to this issue on GitHub: https://github.com/elementary/appcenter/issues/1796

So there is no problem to fix, and you can keep using the computer as usual without any issues as a result of this error message.

2

You can bypass this error by updating/upgrading through the terminal instead of AppCenter.

# downloads package info from all configured sources
$ sudo apt-get update

# upgrades all installed packages from the command above to their latest versions
$ sudo apt-get full-upgrade

apt-get full-upgrade is the same as apt-get upgrade but will also remove packages that are preventing the system from completing the upgrade -- which is what you want.

In my case, running "full-upgrade" removed libpantheon-files-widgets0 and installed the compatible libpantheon-files-core0

After running both apt-get commands, if you still have AppCenter open, make sure you close out of it completely. The next time you navigate to AppCenter you will notice the previous Operating System Updates is now up-to-date and that there are no components in need of updates.

You can also confirm successful upgrade through the terminal by running the following command:

$ lsb_release -a

# No LSB modules are available.
# Distributor ID: Elementary
# Description:    elementary OS 6.1 Jolnir
# Release:        6.1
# Codename:       Jolnir

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.