I am using an Lenovo Legion 5 with an AMD Ryzen 7 5800H and a NVIDIA 3060. When I suspend my laptop, either through systemctl, the wingpanel button, closing the laptop or pressing the powerbutton, it suspends. When I then resume the laptop, it has no backlight. When I connect an external monitor that runs just fine, it's just the laptop screen.

So I've tried a bunch of things and I am running out things to try:

None of these solved the issue. I really don't know what to do anymore, any and all help would be much appreciated.

1 Answer 1


I was able to fix it after all. Updating to kernel 5.14 broke my trackpad, whilst trying to fix that I came across this:


Following that guide fixed all my issues.

  • This is a good resource for people using the same hardware 👍🏻
    – matigo
    Sep 8, 2021 at 7:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.