0

I have an HP EliteBook 8540w (2010 model with i5 and 8GB of RAM, nVidia) with multiboot (Ubuntu 19.10, Elementary Hera, Mint 19.2, Manjaro 18 and Windows 10). For the last month or so, I have severe problems with Suspend with most of the Linuxes that I use. Surprisingly, right now only Win10 supends and resumes fine... The behaviour in Elementary: When I suspend (either from the Power button or withh systemctl suspend or sudo pm-suspend) it sems to suspend allright but, when try to resume, all the leds open, fan runs, display backlight lits up but it does not give me an interface to use. ALt Ctrl F1 (or F*) does nothing. It does not seem to be a graphics issue since I tried to suspend and resume from console (ALt Ctrl F1, login and then systemctl suspend or pm-suspend) but it does the same: at best, it gives me an unresponsive console screen at the point I suspended and the only thing I can do is long press the Power button for a hard shutdown. I tried both X.org and proprietory nVidia drivers with same results, with slight variations, but basically the same result. Journalctl stops at the suspend stage: there are no lines after that to help me debug the resume issue. Any suggestion on how to debug this very annoying behaviour? For my type of use (mostly on battery with frequent pauses where I need to put it to sleep and resume my work few minutes or hours later), it makes it very inconvenient and frustrating.

Thank you in advance for your help, Stavros

0

Perhaps related to these: https://github.com/elementary/switchboard-plug-pantheon-shell/issues/219https://github.com/elementary/switchboard-plug-pantheon-shell/issues/219 https://github.com/elementary/switchboard-plug-pantheon-shell/issues/219

If you also add to the issue on github maybe it will get more attention! :)

  • Thank you for your answer. I'm sorry I did not see it then. It could be related although it is very vague... Anyways, I did not see any meaningful reply to it :( – stavrosc Jun 21 '20 at 21:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.