0

First time question here, so Please forgive/guide me if I'm not doing it right, Thanks !

I'm testing elementary OS 5.1.7 Hera (fresh install from elementaryos-5.1-stable.20200706.iso, I did NOT tweak the OS/install using stuff in terminal or anything). I already had some app updates, including "OS Updates" using AppCenter. All those worked fine and didn't bother me with password stuff and all went smoothly afterwards.

I also installed some other apps using AppCenter : Firefox, Fondo, Norka for example and all went nicely and requesting NO password ...

Now I'm trying to install a .deb (the DownloadVideoHelper.net "companion app") and I found out that to install it I could :

  • install it from AppCenter : in Files (app), right-click on the .deb file and select "open in AppCenter" : that option wasn't present, so I added it (by selecting what app to use for that extension), and when I then used it, it didn't do anything ... (well, AppCenter starts and then stays there on the "Home" tab [it is not frozen/hung, it just doesn't do anything more than that]) ;
  • install using "sudo apt install ./somefile.deb" : apt requires password, so I'm stuck again.

I searched how to install packages in this os and I found that Synaptic Package Manager would be a great alternative choice, so I tried to install that.

Again in AppCenter, searched for synaptic, found it and when I try to install it (by clicking the "Free" button), it wants a password. To check anything else, I tried installing "FreetuxTV" (just because that one fell under my gaze). Same thing : stuck for a password. But this is non-curated, so I thought this could be the issue here. So I tried installing Badger, also Free, but curated. Same problem : I'm stuck again for a password !

BTW, I tried hitting [Return] at the password prompt, just in case it would accept that as some default, since I read that elementary OS has in-built the "no-password required" concept to install stuff in order to avoid "authentication-fatigue" as they say ...

I believe asking "What is the password / How do I reset the password ?" are thus the wrong questions to ask, since the os developers went for the no-password concept cited above.

So you probably already guessed my question : How do I install any further apps from the catalog (or not), if I'm going to be blocked by this password issue ?

I found and read :

  • [https://elementaryos.stackexchange.com/questions/7542/how-can-i-install-deb-files-in-loki] : Eddy might be recommended GUI way, but is NOT Free, so I went for apt "the proper cli way"

  • (read all this one but this is the point of interest) [https://elementaryos.stackexchange.com/a/6973]

  • [https://elementaryos.stackexchange.com/questions/22504/appcenter-failed-to-obtain-authentication], and sudo apt update / upgrade both block me with a password request. And yes I did reboot ...

  • not relevant to my situation but read it anyways (BTW, shouldn't this be in elementaryos.stackexchange ? ) [https://stackoverflow.com/questions/61640553/elementary-os-hera-5-1-cant-login-session-returned-error-code-1-accid]

  • just saw this on the sidebar after I posted : [https://elementaryos.stackexchange.com/questions/24754/installing-deb-file-with-a-double-click] : interesting but not relevant to my question, and AppCenter -> Eddy shows $5, so not Free, contrary to one answer reports, and "dpkg (the way that doesn't resolve dependencies)" seems to be the wrong way to doing things as found in [https://elementaryos.stackexchange.com/questions/7542/how-can-i-install-deb-files-in-loki]

None of the 25 "Similar questions" (if I counted correctly) proposed when I posted this question were relevant to my question.

Thanks in advance for your help !

2
  • All AppCenter apps are free, just type 0 in the donation box. But, when you installed elementary OS, you were prompted to set a password for you account. That same password is used by apt. – Vlad Nov 10 '20 at 10:52
  • so, what is the problem that requires Password? your password is forgotten? – Angel Nov 12 '20 at 15:25
1

There's a lot of content in this "question" so it's hard to fully understand what you're asking. It's often better to ask a succinct question if you want a succint answer, but I'll try and answer some of your points.

In summary, if you have forgotten your password, it's not just installing software you're going to struggle with. Changing certain settings will require a password. Unless you've enabled autologon, you'll need your password to log onto the system and unlock it. And if you have enabled autologon, you will be prompted for your password more frequently as a security measure.

In case it wasn't clear, the password you are being prompted for is the password you set when you installed elementary OS. This is the same password you log into the system with (unless you have enabled autologon).

Now, onto some of your other points:

in Files (app), right-click on the .deb file and select "open in AppCenter" : that option wasn't present, so I added it

This option intentionally doesn't exist since AppCenter does not support installing .deb files. So it's expected that it would do nothing.

AppCenter : Firefox, Fondo, Norka for example and all went nicely and requesting NO password

AppCenter generally prompts for a password for installing new applications. Installing new software onto a computer always carries some small amount of risk, so this acts as a confirmation that you have permission to do this on the computer and have thought about the implications. There are some specific circumstances where AppCenter won't prompt for a password for new installations, these are:

  • You have already recently given a correct password to AppCenter, it won't prompt again for a period of time.
  • You are installing a Flatpak application (e.g. from flathub.org). If you have installed an application from there in the past, other applications from Flathub will be available in AppCenter. These applications are considered slightly more secure, and are often only installed for your user account rather than all users on the system, so we don't prompt for a password here.

I read that elementary OS has in-built the "no-password required" concept to install stuff in order to avoid "authentication-fatigue" as they say

If you have read that there is no password required to install software somewhere, please inform the author of that source that this is incorrect. This is correct for updating software as updating software is usually better than not updating software from a security perspective, but installing new software will always require a password except in the cases mentioned above.

So to answer your question of how to install a .deb file, you are correct that you either need an application like Eddy (preferred) or Synaptic, or you can use the command line sudo apt install ./debfile.deb. However, all of these methods will require a password as installing a .deb file requires administrator permissions.

Eddy shows $5, so not Free, contrary to one answer

Any applications showing a price in AppCenter follow the elementary "pay what you want" model. The $5 is the price the developer has suggested they feel their application is worth. You can choose to pay any amount for it (including $0) if you wish.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.