0

Hi all and thanks for helping me out here!

I want to try Jupyter Notebook (IPython) on my elementary OS Freya installation, but to compile some Jupyter dependencies I also need python3-dev which I am not allowed to install by using apt.

  • which command you used? what is the error? – Ravan Oct 18 '15 at 11:25
  • please let me know if you still have any errors =) – Ravan Oct 18 '15 at 12:56
  • your problem solved ? @nodFlindors – Ravan Oct 20 '15 at 11:48
  • @Ravan i lost a few days, because i removed python3 completely. I had to do a rollback installing ALL the packages that depend on python3.... now my system has other problems :) but i also did an upgrade and after that i could install jupyter and all the dependencies compiled. – nodFlindors Oct 22 '15 at 9:53
  • thats fine =)... – Ravan Oct 22 '15 at 9:56
1

I successfully installed Jupyter using the python package management system PIP.

First install PIP for Python 3 from repositories:

sudo apt-get install python3-pip

then install Jupyter by using PIP:

sudo pip3 install jupyter

After Jupyter got successfully installed, you can start it from terminal:

jupyter notebook

Jupyter

| improve this answer | |
  • well i tried that, but i get an error that i need libpython3-dev and python3.4-dev installed on my system so jupyter dependencies can be compiled during the pip install. – nodFlindors Oct 18 '15 at 12:00
  • ah - you're on a german system! :) – nodFlindors Oct 18 '15 at 12:01
  • sudo apt-get install python3.4-dev Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass Sie eine unmögliche Situation angefordert haben oder, wenn Sie die Unstable-Distribution verwenden, dass einige erforderliche Pakete noch nicht erstellt wurden oder Incoming noch nicht verlassen haben. Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen: – nodFlindors Oct 18 '15 at 12:02
  • 1
    well, it seems that there is something wrong with your system... try running sudo apt-get -f install to fix the unresolved dependencies. – Rafael Oct 18 '15 at 12:13
  • 4
    While I understand it may be easier for you personally to communicate in German, future users of the site are unlikely to be so inclined. Please try to keep recorded discussion in English. – Lewis Goddard Oct 21 '15 at 13:54
1

Open terminal and run the command:

sudo apt-get install build-essential python3-dev

Note: (Use python instead of python3 for legacy Python 2)

i.e.,

sudo apt-get install build-essential python-dev

Alternative:

I found a bug here..and solved the problem by forcefully downgrading

  apt-get install -y \
 python3.4=3.4.0-2ubuntu1.1 \
 python3.4-minimal=3.4.0-2ubuntu1.1 \
 libpython3.4-stdlib=3.4.0-2ubuntu1.1 \
 libpython3.4-minimal=3.4.0-2ubuntu1.1

Note: please note the removing packages before removing.

source here

| improve this answer | |
  • did you try that on your machine? i get an error telling me that i cannot install python3-dev because it depends on libpython3-dev (= 3.4.0-0ubuntu2) and python3.4-dev (>= 3.4.0-0~) - two packages that should not be installed and are beeing kept back... i run a german system so the error message is also in german – nodFlindors Oct 18 '15 at 11:49
  • @nodFlindors please see my edited answer.. – Ravan Oct 18 '15 at 11:52
  • @nodFlindors what is output of python3 -V – Ravan Oct 18 '15 at 11:54
  • ok, so it works on your system. but what do i do? :) thats exactly what i tried. – nodFlindors Oct 18 '15 at 11:55
  • python3 -V => Python 3.4.3 – nodFlindors Oct 18 '15 at 11:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.