0

I want to type japanese characters but I can't setup japanese keyboard. I added new japanese language in settings but it seems that I only can type latin characters with it.

I tried to use IBus, but it sounds like IBus doesn't override system-specified keyboard and I can't find any setting to set IBus as system-default keyboard manager.

1

Go to system settings, then "language & region" and use the "plus symbol" in the lower left of the window to add Japanese as an language. Set region and format as you like. These steps might be optional, I didn't try.

Then click to keyboard settings (lower most left big button). Again click the "plus symbol" on the lower left and search for japanese. When you single click to it, choose a layout to your liking. You can inspect the layout with the small button on the lower left depicting a small latin "a". For some reason the Standard layout is not with any japanese symbols.

Also note that in the same main window you got additional "input method settings" as a button on the lower right.

Reboot or logout to make the new keyboard settings work. You should now have a symbol in the top menu bar where you can switch and inspect your configured keyboard languages & layouts.

If you have issues with IBus not being the "default input method" you can follow the instructions from here: How can I use IBus as the default input method?

If you need other layouts like Hiragana you can check out the instructions here: https://askubuntu.com/questions/28669/how-do-i-get-keyboard-to-write-hiragana-instead-of-katakana

If you like the terminal you can always use sudo dpkg-reconfigure keyboard-configuration for the same stuff.

As a sitenote: I just messed up my own keyboard settings with trying this and for some reason I always need two configured languages for the keyboard so it's working properly.

| improve this answer | |
  • Well... yeah, that works for Katakana, but... how can I type Hiragana then? And, more importantly, how can I type hieroglyphs? I am not sure that standard keyboard suffices for that. – user263096 May 16 at 14:55
  • You are right. I checked every single option one by one and there is no Hiragana. – Sysadmin May 16 at 21:48
  • I updated my answer with some hints for IBus and Hiragana layout. I hope this makes it work. – kladderadatsch May 17 at 17:21
1
+50

Please note Keyobard layout and Input Method are seperated. Keyboard layout should follow your physical keyboard. Then add the required Input Method.

Also, for the Japanese keyboard layout found in eOS. I found no way to do transform and only Katakana can be inputted.


For adding Input Method, please follow these steps.

  • System Settings > Keyboard

System Settings

  • Keyboard > Input Method Settings... Keyboard

  • IBus Preferences > Input Method > Add IBus Preferences

  • Pick the required language

IBus Preferences

  • Pick the input method.

enter image description here


Under General tag, set the Keyboard Shortcuts for changing input method. Tweak other settings to fit your needs.

*Please note Show icon on system tray don't work by default as eOS removed support. enter image description here

Here is the pop-up menu for changing input method.

IBus input select

Choosing character type by clcking that A.

enter image description here

| improve this answer | |
  • The thing is, IBus doesn't work at all. It says to set IBus as default input method in settings, but I can't find any way how to do it. – user263096 May 16 at 14:43
  • What source are you refering? Can you describ your situation? – MA Jacob May 17 at 13:09
  • Well, I do everything right as you show. And IBus daemon is activated, but when I type something, plain english appears. I have even tried to type russian - still, default system keyboard layout is used. – user263096 May 17 at 16:39
  • 1
    Added the 'Chosing charaters type' at the end. Hope it help. – MA Jacob May 18 at 5:13
  • 1
    It may be hidden. Goto 'IBus Preferences > General > Font and Style > Show preperty panel:' to set its behaviour. – MA Jacob May 18 at 14:02
0

Problems solved with installation of im-config and setting ibus method. ありがとう!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.