8

I hail from Asia and am fluent in three languages. This means that I often find myself switching keyboards when I have to type. However, I can't seem to find the way to type in other languages beside English (more specifically, Chinese and Japanese). After I install the language pack and select the keyboard layout for these languages as default, all it does when I switch keyboards is allow me to type English with what is basically an English keyboard.

  • do you want your keyboard to have a different layout with other characters (but one character per key), or are you looking for more advanced input methods like pinyin? – santileortiz Aug 18 '15 at 3:42
4

Go to Settings - Keyboard - Layout (3rd tab). Add a new language by clicking the plus sign (+) at the bottom left and selecting it from a list.

enter image description here

-Tip: You can quickly change between distributions by pressing Alt+Spacebar. The shortkey can be edited under Settings - Keyboard - Shortcuts - Universal Access - Next Keyboard Layout

enter image description here

Also, after adding multiple keyboard layouts, they should be accessible in a panel applet and be switched from there too with the mouse.

enter image description here

0

I found a solution in the russian community

Let me translate it.

  1. sudo apt-get update && sudo apt-get dist-upgrade
  2. sudo apt-get install dconf-editor
  3. Open dconf-editor
  4. Go to org > pantheon > desktop > gala > keybindings
  5. Set switch-input-source and switch-input-source-backward to ['']
  6. To enable switching by Alt + Shift execute following command:

gsettings set org.pantheon.desktop.gala.keybindings switch-input-source "['<Alt>Shift_L', '<Alt>Shift_R']"

Note: you must press Alt first to switch the layout

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.