10

I have found IBus installed in my fresh elementary OS. But I cannot use it over default system layouts. I prefer IBus because, it supports the m17n engine which includes my preferred layout for writing Bengali. From system layouts which is not accessible.

How can I use IBus over the system layouts? If IBus is not usable, then why it is installed by default in elementary OS?

3

Yes you can. First you setup your ibus by command ibus-setup enter image description here


Chose the Input Method tab.

enter image description here

--> Select an input method --> Add language what do you want.
My example is Vietnamese - Unikey as you see in the picutre.
Vietnamese is language
Unikey is type of input


After Add language you will go to Application --> System Settings --> Keyboard --> Universal Access You will see the Next Keyboard Layout is your shortcut to change your ibus. enter image description here


Finally if you want to add your language in your System Tray .
Use this command gsettings set org.gnome.desktop.input-sources sources "[('xkb', 'us'), ('ibus', '**YOUR TYPE**')]"​

Example gsettings set org.gnome.desktop.input-sources sources "[('xkb', 'us'), ('ibus', 'Unikey')]"​

Remember Unikey is my input from vietnamese . Just replace your type.

  • It doesn't work. – JulianLai Jan 9 '16 at 4:21
  • it works but not in libreoffice and other apps. Some apps it works. Something is missing. – Bhikkhu Subhuti Apr 26 '17 at 2:44
  • I don't have the "Next Keyboard Layout" option.. – definera Jan 22 at 9:04
1

You can do the following to solve the problem-

  1. Install your desired input method for IBus.
  2. Run ibus-setup command from terminal.
  3. Select 'Input method' tab and Add your desired input method.
  4. Close 'IBus Setup' and run ibus-daemon -drx in terminal.

It starts IBus daemon but It doesn't show IBus on the panel, but it brings up the input method popup and let us choose our desired input method.

If you IBus to automatically start with the system, then go to Settings > Applications > Startup and add ibus-daemon -drx as a custom command.

If you want to use any QT/KDE applications, you have to install the package ibus-qt4 as well:

sudo apt install ibus-qt4
  • I got the keyboard to be selected and I can select with alt space, but the keys do not work (they used to in gnome). please help. I suspect it is because I have synapse installed. can you verify this synapse bug on your machine? – Bhikkhu Subhuti Jan 28 '17 at 14:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.