3

I'm not able to make Elementary OS use ibus as a default input method (IM). I have installed ibus but I'm not sure what I have to do further. Why I think it's not used as IM is because I've de-selected the "Share same input method among all applications" and still when I switch the language, it is still switched globally. The other reason why I made this assumption is that the OS doesn't take into account what languages I have added in the ibus-setup settings and still uses whatever is chosen in the default settings.

I know this question has been raised before, but I couldn't find a solution.

  • Have you tried any of the proposed solutions in this question? – Mr Shunz Jan 29 at 16:25
  • Yes but without success. I don't even have that option in the "Universal access" settings. – definera Jan 30 at 13:19
0

You can try the following:

  1. Open im-config through terminal

    sudo im-config

    enter image description here

click OK button to go next

  1. Click Yes to update system config. enter image description here

  2. Select Ibus as input method for the system enter image description here

  3. Click Ok and Ok for the next windows. Then restart your computer.


The sudo at step 1 is crucial. Without sudo the system just uses the default setting regardless of what you have chosen.

Also make ibus-daemon auto start with the system by:

System Settings > Applications > Startup

Then add a custom command:

ibus-daemon -drx

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.