0

So I installed fcitx and installed a Japanese font, (Anthy). When I turn it off to type with my US layout keyboard, the special characters are mixmatched. the colon key makes a +. The equality key returns a ^.

I went to system settings > keyboard and found that I was, according to the system, with the US layout.

Any idea how to restore the keyboard layout to default, or how to access the config file?

1

What's used in the second field of the layout? Maybe you can change it to default there. (Or simply delete your current layout and add a fresh one)

  • I tried upvoting your answer but don't have the rep. You helped a lot! Thanks! – MountainClimberi Aug 26 '17 at 12:46
  • I'm glad it helped. If it's the answer to your question you can mark it as correct (should be possible with all reputations) – Eric G Aug 26 '17 at 12:49
0

I did what @Eric G suggested, but I deleted the old layout setting, so that I didn't have any layouts, and clicked that plus button, went down to my language (US English) and selected default. Everything seems to be working! Thanks Eric!

  • stackoverflow.com/help/someone-answers (Not for my reputation, but for anyone searching for something like this in the future, so he knows at a glance, that this answer should be working) – Eric G Aug 27 '17 at 8:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.