0

I manually installed Firefox Developer Edition, added it to the dock, and set it as my default browser. All was good, but now it displays a secondary gear icon in the dock when I open it by clicking a link elsewhere in the OS: screenshot of my dock after Firefox is opened through an external click.

My default browser choice in settings also shows the gear icon. What's going on? screenshot of my Applications settings pane.

Edit with two details to add:

  1. No matter which way Firefox Dev launches, it keeps its state (remembering open tabs, etc.). So if it launches via an external click of a URL, then I quit and reopen using the dock icon, it still has that tab open.
  2. If I already have Firefox Dev open via the dock or Applications launcher and then I click a link in another program, it opens a new tab in the open Firefox Dev instance and does not add that other icon to the dock.
1

I found the same issue when setting Firefox Developer Edition as my default browser. Then when opening the default browser using a shortcut, it opens a separate dock icon.

I looked in ~/.local/share/applications and found the added shortcut. It looks like it was using firefox-bin as the executable.

If you change the executable in your custom shortcut to point to firefox-bin it should fix the issue. (it did for me)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.