2

I did a sudo apt install libpng16-dev to upgrade filezilla. but it removed a lot of dependencies.

Now I can't install elementary-sdk and plenty of other depencies, the following error occurs.

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 elementary-sdk : Depends: libgala-dev but it is not going to be installed
                  Depends: libgranite-dev but it is not going to be installed
                  Depends: libgtk-3-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I tried fixing broken packaged at the recovery menu but it didn't work. How can I fix this. I am running Loki

0

You can remove FileZilla and libpng16-dev, reinstall the SDK, and then install FileZilla via Flatpak:

https://flathub.org/apps/details/org.filezillaproject.Filezilla

  • I already did that, I get an error now that says elementary-sdk : Depends: libgala-dev but it is not going to be installed I tried installing libgala-deb but it shows me the same error but asking for libmutter. – Carlos Flores Oct 14 '18 at 3:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.