0

As soon as I inserted my USB card it was simple plug and play. So, when I connected to my AP both card (internal and USB) would connect to it. My access point will show two devices connected to it (both the names point to my laptop). So when I tried to disable my internal card, I used the following steps:

Add the following line to /etc/network/interfaces:

iface wlan0 inet manual

We can replace wlan0 with the interface name that we want to disable. It worked there was no sign of my internal card. So when I again pluged my USB card the simple plug and play method won't work anymore. But when I enabled my internal USB card it started working again but same as earlier both card would connect to my AP.

How can I disable my internal card and make use of my new USB card.

0

We can simply blacklist the modules which we do not want to use.
To blacklist the module of your wireless card :

1. sudo vi /etc/modprobe.d/blacklist.conf (If you can not find it you can create one).

2. Comment the module name with a # in the beginning of the line:

#blacklist wlan0

3. Save, run sudo update-initramfs -u and reboot

To remove a module manually without rebooting :

sudo modprobe -r wlan0

Looses effect after reboot.

To load the module again:

sudo modprobe wlan0

To check the modules were loaded or not :

sudo lsmod

I found the answer from here. This worked for me, however if you have other problem regarding this you can check the link. It has tons of answer.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.