1

I have come to this issue since yesterday that the only way I can get internet from using my computer is by sharing my phone's connection via USB. My wifi card seems like it is not even activated.

I am running ElementaryOS Loki and it worked fine until I woke up my computer from sleep mode yesterday.

It should be important to know that I am running a dual boot and that wifi works fine on my Windows 7 system so it is not a hardware issue. When I run lspci -nn | grep -i network I get :

0a:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11bgn Wireless Network Adapter [14e4:4727] (rev 01)

I tried updating my network card's drivers but it didn't work, at this point I don't really know what to to to get internet back normally on my computer.. Does any of you know where the issue come from and/or how to fix this? I believe it could be the drivers not installing properly since there are a bunch of errors when I install them, in particular modprobe: FATAL: Module wl not found in directory /lib/modules/4.15.0-24-generic which I don't know how to fix.

Thanks in advance for your help.

0

Broadcom drivers reported to broke for many users after the kernel update.

Take a look at this post: BCM43142 and linux kernel 4.15.0-24-generic

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.