1

I am attempting to make the switch from Windows to Linux, and decided to give Elementary a try. I installed Loki, but I and unable to get WiFi working. It did not work when I booted from the install USB, and it didn't work after I installed it. I'm working with an MSI laptop, with an Intel Dual band Wireless-AC 3168 card.

The kernal of Elementary that I have installed is:

4.4.0-38-generic #57-Ubuntu SMP Tue Sep 6 15:42:33 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

When I run rfkill list all, my results are:

0: hci0: Bluetooth
Soft blocked: no    
Hard blocked: no

When I run sudo lshw -class network, my results are:

*-network UNCLAIMED     
description: Network controller
product: Intel Corporation
vendor: Intel Corporation
physical id: 0
bus info: pci@0000:02:00.0
version: 10
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress cap_list
configuration: latency=0
resources: memory:df200000-df201fff

*-network
description: Ethernet interface
product: QCA8171 Gigabit Ethernet
vendor: Qualcomm Atheros
physical id: 0
bus info: pci@0000:03:00.0
logical name: enp3s0
version: 10
serial: 4c:cc:6a:dc:41:31
capacity: 1Gbit/s
width: 64 bits
clock: 33MHz
capabilities: pm pciexpress msi msix bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=alx latency=0 link=no multicast=yes port=twisted pair
resources: irq:128 memory:df100000-df13ffff ioport:d000(size=128)

From what I'm seeing, Elementary just isn't seeing the WiFi card, or at least isn't seeing it correctly. I Googled various solutions for a couple of hours, but didn't find anything that worked. Does anybody have an idea about what I can do to solve this?

I hate to say it, but if I can't resolve this, Im either going to have to try a different Linux Distro, or just plan on sticking with Windows for now.

Thanks for any help of advice you can offer.

2

At the time I am writing, the most current stable kernel is 4.10.8. MSI laptops with Killer Networking are reportedly working on recent Linux kernels. Their support page says so.

Try updating your Linux kernel. Easiest way is probably via Ukuu.

If it helps, I'm running elementaryOS Loki on an MSI Leopard Pro GP62M-7RD and everything works fine after updating the kernel.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.