1

I installed elementary OS 7 on my laptop 2 days ago. In the beginning everything was working well, but today my Wifi simply stopped working. I can see no available connections in the network list and although I'm able to connect to the internet through a wired connection, I cannot create a hotspot on my computer. I'm not shown any error when I turn the hotspot on, but it doesn't show up as an available connection to other devices in the vicinity. Running dmesg shows the following error messages which I believe are related:

[  107.750470] rtw_8822be 0000:07:00.0: failed to read ASPM, ret=-5
[  109.749418] rtw_8822be 0000:07:00.0: failed to poll offset=0x5 mask=0x2 value=0x0
[  109.749434] rtw_8822be 0000:07:00.0: mac power on failed
[  109.749436] rtw_8822be 0000:07:00.0: failed to power on mac
[  109.749438] rtw_8822be 0000:07:00.0: leave idle state failed
[  109.749624] rtw_8822be 0000:07:00.0: failed to leave ips state

Running lspci reveals this to be my wifi card: Network controller: Realtek Semiconductor Co., Ltd. RTL8822BE 802.11a/b/g/n/ac WiFi adapter

Any help on solving this issue is much appreciated. Thanks in advance.

Update: After following Vlad's suggestions, some of the error messages disappeared, namely the ones related to ASPM, but I see the following new ones now:

[    6.568678] rtw_8822be 0000:07:00.0: Unable to change power state from D3cold to D0, device inaccessible
[    6.575083] rtw_8822be 0000:07:00.0: failed to setup chip efuse info
[    6.575114] rtw_8822be 0000:07:00.0: failed to setup chip information

1 Answer 1

2

I have the same adapter, and I had to install driver from https://github.com/lwfinger/rtw88 to make it work:

Install dependencies:
sudo apt-get update
sudo apt-get install make gcc linux-headers-$(uname -r) build-essential git

Clone the repo:
git clone https://github.com/lwfinger/rtw88.git

Build and install driver:
cd rtw88
make
sudo make install
sudo reboot

I now have 99% consistent WiFi connection, even between resumes & restarts.

OBSERVATIONS:

  1. You'll need to install the driver after every kernel update, so keep the cloned folder at hand.
    cd ~/rtw88
    git pull
    make
    sudo make install

  2. Sometimes, after a restart, WiFi will be off, trying sudo rfkill unblock all might work, or turn off laptop, remove power supply, wait a minute or two, power on laptop. Inside the repo folder there's a suspend script, might want to try it if you have serious issues with dead WiFi after suspend sudo cp suspend_rtw8822be /usr/lib/systemd/system-sleep/

  3. You may also need to turn aspm off after installing the driver:
    sudo nano /etc/modprobe.d/r8822be.conf
    inside this file paste options r8822be aspm=0
    Ctrl+O to save file
    Ctrl+X to close nano
    reboot

11
  • I tried this, and although it worked at first, rebooting broke it again. I tried rebooting multiple times, and found that although the wifi works sometimes it's not nearly as consistent as yours. Any further ideas? May 30, 2023 at 11:21
  • You may also need to turn aspm off for the card. I added one extra step at my answer
    – Vlad
    May 30, 2023 at 14:29
  • I've now turned the aspm off as suggested. At the moment it seems to be working. Hopefully reboots won't break it like last time around May 30, 2023 at 15:13
  • I hope it stays stable. If it fails, in my case, it happens about 1 minute after power up. From what i read, it's a power management issue with the realtek chips, and also sometimes the OS cannot read the 'state' of the chip at power up
    – Vlad
    May 30, 2023 at 15:40
  • Sadly the stability does not seem to have improved. Although it was working yesterday, it has died again today. A notable thing however is that the ASPM related error messages don't show anymore, but there are new error messages that weren't there previously. I've appended these to the original post. Jun 1, 2023 at 4:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.