1

The networking icon only has options for wired, and is missing a wireless option. The rtl8812au-dkms driver is identified by the AppCentre. I've tried multiple troubleshooting tips from other similar scenarios, but had no luck so far. The usb wifi stick works perfectly fine when elementary is running from a live usb, but as soon as the OS is installed it stops working. I have secure boot off in my bios.

Below are some commands and their outputs which I hope will help in diagnosing this issue.

lsusb:

Bus 001 Device 010: ID 0bda:8812 Realtek Semiconductor Corp. RTL8812AU 802.11a/b/g/n/ac WLAN Adapter

dkms status rtl8812au:

rtl8812au, 4.3.8.12175.20140902+dfsg, 4.15.0-65-generic, x86_64: installed
rtl8812au, 4.3.8.12175.20140902+dfsg, 4.15.0-69-generic, x86_64: installed

iwconfig:

lo        no wireless extensions.

enp0s31f6  no wireless extensions.

rfkill list all:

0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

So if my (limited) understanding is correct, the usb stick is detected fine and the drivers are installed, but the networking capabilities aren't available? I'm happy to edit with any more outputs that would be helpful.

Thanks

  • Didi you give this or this a try? – Vlad Pop Nov 13 at 6:32
  • The first link uses a repo that I don’t think I’ve tried yet. I’ve used the second one previously and had no luck. Thanks for that first link, I’ll give it a try as soon as I have access to my computer again and update here. – Shawn Nov 13 at 14:50
  • The final update in that first link provides the first of the three or four repos I've tried that actually works for me, provided I ignore the instructions given and install without dkms. I guess the issue is in the dkms part, but avoiding the problem is as good as solving it to me after all this time. Thanks so much! If you post it as an answer, and possibly include the link to the repo (github.com/AstroDrabb/rtl8812au) I'll happily accept it. Maybe it'll help someone else like me who's tried most of the recommended solutions and had no luck. – Shawn Nov 14 at 1:04
  • Wonderful! I created an answer containing the working repository, with a short list of instructions. Please review it and accept it, if satisfactory. It would also be awesome if you edited your question to include the model of your USB WiFi adapter. Thank you for taking the time to test the driver against your hardware. – Vlad Pop Nov 14 at 8:11
0

Compiled from comments: The instructions on How to install Realtek rtl8812au WiFi Driver in Linux seem to work for this wifi device. The article refers to a GitHub repo containing a version of the rtl8812au linux driver, updated to compile against newer kernels. Since there is a huge list of USB WiFi adapters built using this chip, we can expect a flow of requests regarding installing it.

Here's a summary:

git clone https://github.com/AstroDrabb/rtl8812au
cd rtl8812au
sudo ./install.sh
**follow the script's instructions**

The above repository also contains instructions on adding the driver to dkms, so that it survives kernel update.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.