I'm running Loki on a spiffy system more or less without fail. There are a couple of little bugs but nothing that makes me want to jump immediately back to Ubuntu. Unfortunately, I have found a trouble spot that is making it difficult for me. VirtualBox is not working.

I'm running 4.8.0-32-generic kernel, which I upgraded to as a result of issues I was having with Intel 8265 wifi card (Intel 8265 doesn't work in Loki)

The error I get when trying to spin up a virtual disk, in this case FreeBSD is as follows:

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please install virtualbox-dkms package and load the kernel module by executing

'modprobe vboxdrv'

as root. If it is available in your distribution, you should install the DKMS package first. This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary.

where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT. 

So I've tried some of the support noted on stack here for Elementary but none of it works. Any ideas?

Trouble installing Virtualbox on Freya with kernel 4.4.0

VirtualBox on elementaryos

  • I get the same results with kernel
    – Levo75
    Jan 10, 2017 at 22:27

2 Answers 2


This is what works for me (keeping secure boot enabled), but you will need to do it every time the kernel is updated:

1. Create signing keys

openssl req -new -x509 -newkey rsa:2048 -keyout MOK.priv -outform DER -out MOK.der -nodes -days 36500 -subj "/CN=Descriptive name/"

2.Sign the module (vboxdrv for this example)

sudo /usr/src/linux-headers-$(uname -r)/scripts/sign-file sha256 ./MOK.priv ./MOK.der $(modinfo -n vboxdrv)

3. Register the keys to Secure Boot

sudo mokutil --import MOK.der

Supply a password for later use after reboot

4. Reboot


and follow instructions to Enroll MOK (Machine Owner Key). Here's a sample with pictures. The system will reboot one more time. After the reboot, you may also need to

sudo modprobe vboxdrv 

to load the module.

SOURCE: https://askubuntu.com/questions/760671/could-not-load-vboxdrv-after-upgrade-to-ubuntu-16-04-and-i-want-to-keep-secur

  • I'm getting an error: modinfo: ERROR: Module vboxdrv not found
    – Zach
    Jan 10, 2017 at 22:42
  • Sounds like you should reinstall VirtualBox Jan 11, 2017 at 11:43

I had that problem and I solved it with downloading VirtualBox from Oracle website and installing from dpkg. :) (Of course a before I purged everything with virtualbox).

It's a problem with multiple kernels - it came up after updating VirtualBox to newest version.

  • That doesn't work for me unfortunately. dpkg throws some interesting errors primarily around gcc make not being available. However, apt install on that says I'm fine. cat the install.log of vbox and it is full of kernel dependency errors and all kinds of crap I don't understand. Seems like this is going to be a no-go for me. I don't have time to troubleshoot unfortunately.
    – Zach
    Jan 11, 2017 at 17:08
  • Well, I know that pain bro :/ I suffered from this problem for a long time and only that helped :< I wish you quick solution. :)
    – Dysproz
    Jan 11, 2017 at 17:43
  • Yeah it's a real bummer because to me ElementaryOS is far superior to Ubuntu. I've already donated because I believe it's a great distribution to start on and I'm really enjoying it. Are there bugs, yeah, totally, but they are manageable. And, in truth VM'ing isn't like novice stuff so I don't blame them for not having it sorted out in a beta. I'll keep hacking away at it.
    – Zach
    Jan 11, 2017 at 19:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.