2

I've had VirtualBox 5.0.40 running on Loki for a while now without issues, but recently (as in the last few days) I suspect one of the many OS updates (which probably are to mitigate the various new vulnerabilities discovered) has broken VirtualBox. If I start a virtual machine, it starts loading, but before the guest machine even gets to the POST, my entire computer freezes. Only recourse is to hold down power and forcefully shut the machine down. Can't use CTRL-F1 to go to a terminal either. It completely freezes. Haven't used VirtualBox for a few days, so don't know which update caused it, but one probably did. Anyone else seen this? Any idea how to fix it?

  • Have you had any success with other virtual tools, i.e., Virt Manager or Gnome Boxes? – Pretzel Jones Jan 12 '18 at 13:10
  • Haven't tried any others. I use VirtualBox cause it has good performance and is generally well supported. It's apparently also one of the more feature full virtual tools out there (beside VMWare and MS). And I don't really want to go hopping from one environment to another, potentially having to recreate VMs. Petr answer below was helpful in that it confirms it's due to the recent updates. – OlgerD Jan 14 '18 at 6:38
  • I have the exact same issue. I'm also using VB 5.0.40 on Loki – RTbecard Feb 13 '18 at 11:35
0

I only can confirm this behaviour. :{ VirtualBox 5.0.40, Loki 0.4.1, Linux 4.13.0-26-generic //// Update //// Explanation and solution: https://askubuntu.com/questions/994315/virtualbox-crash-on-kernel-4-13-0-26/994320#994653 Works for me OK.

  • Same version of VirtualBox and Loki. Thank you for the link. It confirms my suspicions. Hopefully it'll be fixed soon. – OlgerD Jan 14 '18 at 6:39
0

Ended up installing VirtualBox 5.2 following the instructions here: https://www.virtualbox.org/wiki/Linux_Downloads I tried using 5.2 a while ago and had some issues, but with the newer kernel they seem to be fixed. So far it's all working well.

0

May have found a fix for this, do a cheeky upgrade to 5.2:

Uninstall all traces of Virtualbox.

Install the non-authenticated version of 5.2:

sudo apt-add-repository -y 'deb http://download.virtualbox.org/virtualbox/debian xenial contrib'
wget -q https://www.virtualbox.org/download/oracle_vbox.asc -O- | sudo apt-key add - 
sudo apt-get update
sudo apt-get install -y dkms
sudo apt-get install -y virtualbox-5.2 --allow-unauthenticated

(Courtesy of https://gist.github.com/ankurk91/2327d4881d71a098e3bfcd0b1c255d83)

Check if dkms is installed:

dpkg -l | grep virtualbox-dkms

If so, uninstall then reinstall dkms:

sudo apt-get purge virtualbox-dkms && \
sudo apt-get install dkms

Then rebuild the kernel modules:

sudo /sbin/vboxconfig

Worked for me at least.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.