2

I am having some problems installing Virtualbox on my Elementary Freya. Due to some hardware, I needed to install Linux Kernel 4.4. However, I can't seem to install Virtualbox properly. (I was using rc3 previously, just updated to rc7)

$ uname -r
4.4.0-040400rc7-generic

I downloaded and tried both version from the website.

virtualbox-5.0_5.0.12-104815-Ubuntu-trusty_amd64.deb
virtualbox-5.0_5.0.12-104815-Ubuntu-wily_amd64.deb

Both of it fails.

$ sudo /etc/init.d/vboxdrv setup
Stopping VirtualBox kernel modules ...done.
Uninstalling old VirtualBox DKMS kernel modules ...done.
Trying to register the VirtualBox kernel modules using DKMSERROR (dkms apport): kernel package linux-headers-4.4.0-040400rc7-generic is not supported
Error! Bad return status for module build on kernel: 4.4.0-040400rc7-gen onsult /var/lib/dkms/vboxhost/5.0.12/build/make.log for more information....failed!
(Failed, trying without DKMS)
Recompiling VirtualBox kernel modules ...failed!
(Look at /var/log/vbox-install.log to find out what went wrong)

Any ideas how to fix this? Many thanks in advance.

  • try sudo apt-get --reinstall install virtualbox-dkms and let me know :). Also see here – Ravan Jan 8 '16 at 10:59
  • 1
    have you tried sudo apt-get install build-essential linux-headers-`uname -r` dkms ? – Ravan Jan 9 '16 at 11:05
  • 1
    @Ravan running that command states that dkms and build-essential are both up-to-date, and linux-headers-4.4.0 cannot be downloaded through apt-get. I downloaded the kernel update from here: kernel.ubuntu.com/~kernel-ppa/mainline/v4.4-rc7-wily – jellene Jan 10 '16 at 7:33
  • 1
    then try installing headers manually and let me know – Ravan Jan 10 '16 at 9:59
  • 1
    @Sneetsher No, updating to any of the 4.4 linux headers won't work. I haven't tried downgrading back to the original packaged linux headers for 14.04 LTS. Will reply here when I do. – jellene Jan 21 '16 at 5:09
1

I needed gcc4.9-multilib to recompile my DKMS modules after the upgrade.You can grab it out of the toolbox beta repository from Ubuntu.

If that didn't work, post the log:

cat /var/lib/dkms/vboxhost/5.0.12/build/make.log
0

It seems the version number is out of range of supported kernels because have this format 4.4.0-040400rc7-generic but it have to be something like X.X.X-XXX

You could use a kernel from ubuntu repositories. Do you really need to use the 4.4 version?

sudo apt install linux-generic-lts-wily
  • everything works like a charm with that format too. – Phil Jacobs Apr 1 '16 at 10:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.