2

My kernel updated recently and since then I get the following error when attempting to start my Windows 10 VM:

Kernel driver not installed (rc=-1908)The VirtualBox Linux kernel driver (vboxdrv) 
is either not loaded or there is a permission problem with /dev/vboxdrv. 
Please reinstall the kernel module by executing  '/etc/init.d/vboxdrv setup'as root. 
If it is available in your distribution, you should install the DKMS package first. 
This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary.

where: suplibOsInit
what:  3
VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT.

I have scoured the internet trying to find a solution to the problem but nothing seems to work. Almost all of the solution suggest installing DKMS, this had no effect for me. Others suggest reinstalling DKMS, installing all of these packages:

sudo apt-get install linux-generic linux-image-generic linux-headers-generic linux-signed-generic

And then reinstalling Virtualbox. I tried installing the above and was terrified when I saw different kernel modules being downloaded. "Luckily" they all failed to install and my system is still stable.

I have the 3.16.0-67-generic kernel on elementary OS 0.3.2 Freya 64-bit on a Dell Latitude E7240.

I really need to use the VM, if anyone can help that would be great!

Running

/etc/init.d/vboxdrv setup

Produces:

bash: /etc/init.d/vboxdrv: No such file or directory

Running:

sudo dkms autoinstall

Produces:

Kernel preparation unnecessary for this kernel.  Skipping...

Kernel preparation unnecessary for this kernel.  Skipping...
applying patch 0001-MODULE_LICENSE.patch...patching file src/wl/sys/wl_linux.c
Hunk #1 succeeded at 156 (offset -3 lines).

applying patch 0002-Makefile.patch...patching file Makefile
Hunk #1 succeeded at 113 with fuzz 1.
Hunk #2 succeeded at 132 with fuzz 2 (offset 1 line).

applying patch 0003-Make-up-for-missing-init_MUTEX.patch...patching file src/wl/sys/wl_linux.c
Hunk #1 succeeded at 111 with fuzz 2 (offset 12 lines).

applying patch 0010-change-the-network-interface-name-from-eth-to-wlan.patch...patching file src/wl/sys/wl_linux.c
Hunk #1 succeeded at 221 (offset -14 lines).

applying patch 0011-do-not-define-__devinit-as-__init-in-linux-3.8-as-__.patch...patching file src/include/linuxver.h

applying patch 0012-add-support-for-Linux-3.15.patch...patching file src/wl/sys/wl_cfg80211_hybrid.c
Hunk #1 succeeded at 2071 (offset 230 lines).

applying patch 0013-gcc.patch...patching file Makefile

applying patch 0014-add-support-for-Linux-3.17.patch...patching file src/wl/sys/wl_linux.c
Hunk #1 succeeded at 1313 (offset -38 lines).

applying patch 0015-add-support-for-Linux-3.18.patch...patching file src/wl/sys/wl_cfg80211_hybrid.c


Building module:
cleaning build area...
Building module:
cleaning build area....
make KERNELRELEASE=3.16.0-67-generic -C /lib/modules/3.16.0-67-generic/build M=/var/lib/dkms/bcmwl/6.30.223.248+bdcom/build....
make KERNELRELEASE=3.16.0-67-generic -C /lib/modules/3.16.0-67-generic/build M=/var/lib/dkms/virtualbox/4.3.36/build....(bad exit status: 2)
.(bad exit status: 2)
ERROR (dkms apport): kernel package linux-headers-3.16.0-67-generic is not supported
Error! Bad return status for module build on kernel: 3.16.0-67-generic (x86_64)
Consult /var/lib/dkms/virtualbox/4.3.36/build/make.log for more information.
ERROR (dkms apport): kernel package linux-headers-3.16.0-67-generic is not supported
Error! Bad return status for module build on kernel: 3.16.0-67-generic (x86_64)
Consult /var/lib/dkms/bcmwl/6.30.223.248+bdcom/build/make.log for more information.
1

Try running the following commands in the terminal

sudo apt-get install g++-5
sudo apt-get install gcc-5
sudo rm -f /usr/bin/g++
sudo rm -f /usr/bin/gcc
ln -s /usr/bin/gcc /usr/bin/gcc-5
ln -s /usr/bin/g++ /usr/bin/g++-5
sudo apt-get install --reinstall virtualbox-5.0

This worked for me after updating to kernel 4.4 LTS to get VirtualBox working so I can do my OS development

  • I tried installing the packages but apt cannot find the packages. Is there a PPA I need, and if so which one? – SpydaMonky Apr 4 '16 at 17:29
  • Run dkms autoinstall if you want to use old VirtualBox or follow the instructions @ virtualbox.org/wiki/Linux_Downloads to get the latest version – Suici Doga Apr 5 '16 at 1:13
  • The autoinstall fails because the kernel is unsupported. I've tried following the instructions on the Virtualbox website and it still says my kernel modules are unsupported. I feel like I need to change my kernel some how? – SpydaMonky Apr 5 '16 at 10:22
  • Try linuxdaddy.com/blog/install-kernel-4-4-on-ubuntu to install the latest 4.4LTS kernel – Suici Doga Apr 6 '16 at 2:16
  • I have now installed the gcc packages but every time I run anything to do with the kernel it fails because it is unsupported... – SpydaMonky Apr 6 '16 at 7:05
-1

Try reinstalling the VirtualBox kernel driver:

/etc/init.d/vboxdrv setup

Yesterday I updated to 4.4 and needed another gcc package to get some of my kernel modules via DKMS working again, a build log from:

dkms autoinstall

would be quite useful if the setup command didn't work.

  • I have updated the question – SpydaMonky Apr 2 '16 at 9:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.