7

I just installed Loki over my Freya VM that I've been using for the last year and was surprised by the performance difference. It's barely usable.

Cursor hover, clicks, and keyboard input take up to a second to register. Video output in response to user events happens at similar framerates (such as changing the background, instead of a fade, it's a few choppy frames).

Fresh install with plenty of CPU and memory on the host and the exact same VM configuration and host I used for Freya.

I suspect the problem is actually with the video output rather than the actual input, and processes in the background seem to run at full speed.

Host Info

  • macOS 10.11.6
  • 16GB RAM
  • 3Ghz i7 Dual-Core

Virtualization Info

  • VirtualBox 5.0.26 w/ Extension Pack
  • 2GB RAM
  • I/O APIC, PAX/NX, Nested Paging
  • 1 CPU, no Execution Cap
  • 128MB Video Memory, 3D Acceleration, Scaled HiDPI (low res)
  • USB 3.0 xHCI Controller (also tried with USB 2.0 EHCI Controller)
  • Guest Utils Installed from VirtualBox virtual CD-ROM Image (DKMS, linux-kernel-headers-generic, build-essential packages installed via apt)

Inline Update

  • Disabled 3D Acceleration in Virtualbox - noticed massive improvement in responsiveness, confirming(?) my suspicion that the problem lies in the video rendering and not from input lag.

So the real question is why does Loki's 3D VM Accelerated performance suffer so hard in comparison to Freya's?

  • Having the same issue. Last good eOS version was Luna. I am giving up -- even on bare-metal, it is getting slower and slower; and more ugly, too (and yes, I do have the same machine like you do). Plus, what is annoying me -- eOS developers basically say we all are bunch of retards, so they disabled deb installations, PPA etc. OK, some of the issues can be resolved, but still. Nope. Not a distro for me. Not anymore. (PS: 3D in VB works -- for me -- only with CentOS and Ubuntu. SuSE does not {hmm, do not know why}.) – olaf Dec 13 '16 at 0:46
  • The performance is so bad, because of VirtualBox's guest additions. I just installed eOS 0.4 Loki and it runs fine. As soon as I installed guest additions (and nothing else) and restarted, my installation got unusable. – Cubi73 Dec 17 '16 at 14:50
  • Disabling 3D acceleration worked for me as well. My eOS Loki installation (with guest additions installed) now runs as smoothly as eOS Freya did before. – Cubi73 Dec 17 '16 at 15:24
  • Running gala --replace fixes it temporarily. So perhaps a mutter or gala issue? – benwaffle Dec 30 '16 at 18:04
1

I am also on Freya and when I installed it in my Ubuntu 16.04, It worked fine. I didn't installed the Guest Additions, so try to remove them. And when I installed I used 2 CPUs. So also increase CPU count.

My host info:
CPU: i3-5005U @ 2.00GHz
RAM: 3.8 GiB

My VM info:
CPU: 2 CPUs, no execution cap.
RAM: 1.9GB
VRAM: 128MB

Hope it helps!!

  • 1
    The guest additions help in so many other areas, removing them is a deal-killer for me. – Anthony Michael Cook Mar 9 '17 at 5:57
0

You need to allocate 512 more MB of ram to it is my guess, a different OS needs different things. At least different versions. But because it is graphical, allocate 1 GB of VRAM to it. Also remove Guest Additions.

  • I allocate at least 2GB to the VM RAM. The guest additions help in so many other areas, removing them is a deal-killer for me. – Anthony Michael Cook Mar 9 '17 at 5:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.