0

I just purchased a 2016 hp specter x360 (7th gen Intel) that comes equipped with an Intel 8265 dual band wifi (https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi).

In the initial installation I noticed that the wireless wasn't coming up after reboot. So I took a look in /lib/firmware and confirmed that the 8265 firmware were not present.

I managed to track down a USB wireless dongle (Belkin/Realtek) to get myself online and performed the standard system updates. That brought me from kernel 4.4.38 to 4.4.57-generic.

Now when I look at /lib/firmware I do in fact see that 8265 firwmare is included. My heart skips a beat because now my wifi adapater should work, right?

Well, reboot and poof. Nada. It just doesn't come up. It is recognized by the system I believe (01:00.0 Network controller: Intel Corporation Device 24fd (rev 78)):

 lspci
00:00.0 Host bridge: Intel Corporation Device 5904 (rev 02)
00:02.0 VGA compatible controller: Intel Corporation Device 5916 (rev 02)
00:04.0 Signal processing controller: Intel Corporation Skylake Processor Thermal Subsystem (rev 02)
00:13.0 Non-VGA unclassified device: Intel Corporation Device 9d35 (rev 21)
00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
00:15.0 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller (rev 21)
00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI (rev 21)
00:1c.0 PCI bridge: Intel Corporation Device 9d11 (rev f1)
00:1c.4 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port (rev f1)
00:1d.0 PCI bridge: Intel Corporation Device 9d18 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Device 9d58 (rev 21)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)
00:1f.3 Audio device: Intel Corporation Device 9d71 (rev 21)
00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
01:00.0 Network controller: Intel Corporation Device 24fd (rev 78)
6d:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd Device a804

depmod doesn't show my the firmware is loaded at all.

I can confirm that this wifi chip works perfectly fine in Ubuntu 16.10 and Ubuntu Mate 16.10.

Any thoughts on how I can get it enabled?

4

See if sudo apt-get install linux-generic-hwe-16.04-edge gets the 4.8 kernel installed and then do

wget http://mirrors.kernel.org/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.161.1_all.deb
sudo dpkg -i linux-firmware_1.161.1_all.deb

Reboot

  • This also fixed my Intel 8260 bluetooth issue (not working)! thanks – Demwunz Jan 23 '17 at 22:00
0

Just as completion to Jeremy31 post. On this date, when I tried using the fix, the apt-get command installs the 4.10 kernel, not 4.8. The WiFi somewhat works. I used the original firmware in that post and the 1.165 one from the same link folder. They both work pretty much the same. The WiFi is functional, but it has a big loading time for web pages. I do not know if this is because it has some drops or anything else.

P.S. I used an answer, and not a comment, because my reputation is too low. Maybe worth mentioning: I have a Clevo P650 . Maybe guys buying the same hardware find this thread faster this way.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.