I've been searching around on here and haven't located an answer.

The OS install went well, but I have no wireless connections available. My machine is a Dell XPS 12 9250. It is running an Intel chip set.

Can someone point me in the right direction please?

  • Run this command to check your wireless card > sudo lshw -C network I did some research and your XPS 12 should have working wifi right out of the box. Did it work in the livecd? Have you tried any other distributions as well? Aug 29, 2016 at 21:16
  • Thank you for the reply. I assumed it would work out of the box as well after a bit of research. That was not the case. I didn't bother with the LiveCD as I've been running UBuntu with no issues. I love Elementary and will tinker around with it some more. I did several installs and was able to replicate the issue every time. I reinstalled the latest Ubuntu. Here is the network card info running the command in Ubuntu: *-network description: Wireless interface product: Wireless 8260 vendor: Intel Corporation physical id: 0 bus info: pci@0000:6c:00.0 logical name: wlp108s0 version: 3a serial: a4:
    – user6012
    Aug 31, 2016 at 16:34
  • Ah, thanks! That makes sense! There's no ethernet port of the XPS 12, so I will have to do a work around and update manually. I appreciate your time and efforts! Thank you again! John
    – user6012
    Sep 2, 2016 at 13:59
  • Try connecting the internet through Bluetooth, if you know how to do it. Sep 2, 2016 at 17:05
  • You can also try this tutorial in a different Ubuntu machine. elementary208.blogspot.ca/2016/08/… Sep 2, 2016 at 17:10

2 Answers 2


So after doing some research. It seems you need to upgrade the linux-firmware and the kernel.

Connect your machine to a LAN network and run the Update Manager to get the newest upgrades, or simply just upgrade these packages.

sudo apt-get install --install-recommends linux-generic-lts-xenial xserver-xorg-core-lts-xenial xserver-xorg-lts-xenial xserver-xorg-video-all-lts-xenial xserver-xorg-input-all-lts-xenial libwayland-egl1-mesa-lts-xenial

Then download the newest linux-firmware


Install the package and restart Elementary. Hopefully that should work.


I currently experience wifi driver issue with eOS 5.1 / Hera on Kernel version 5.0 live-running on Dell XPS 15 (7590) FHD.

I get no wifi out of the box, it doesn't recognize any wifi card. when i do sudo lshw -C network , I only see the Bluetooth card. Unfortunately, the laptop doesn't have an Ethernet card, therefore i could only access internet thru usb tethering ( didn't work) or bluetooth ( didn't work).

After doing some research I found the issue could be the kernel, and said kernel needs to be update to 5.1 or higher version.

I just tried PopOS ( the latest version as of this writing ) and it comes with kernel 5.3. -> all works fine, wifi card is recognized and works no problem.

eOS team needs to update the kernel to +5.1

EDIT 4.19

I just tried the latest of Elementary OS 5.1 with kernel 5.3 finally. Guess what ? ---> NO MORE WIFI PROBLEMS & BT works great as well from the live-usb. Now I'm considering seriously installing it.

Thanks eOS Team

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.