0

enter image description hereI entered the following code with the respective outputs

    rfkill list all

0: ideapad_wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
1: ideapad_bluetooth: Bluetooth
    Soft blocked: yes
    Hard blocked: yes
2: hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no
3: phy0: Wireless LAN
    Soft blocked: yes
    Hard blocked: no

sudo lshw -class network

  *-network               
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: enp2s0
       version: 15
       serial: a8:1e:84:65:91:a9
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8168h-2_0.0.2 02/26/15 ip=192.168.1.19 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:125 ioport:e000(size=256) memory:d1104000-d1104fff memory:d1100000-d1103fff
  *-network DISABLED
       description: Wireless interface
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlp3s0
       version: 99
       serial: 98:54:1b:f3:a6:56
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=4.8.0-52-generic firmware=22.391740.0 latency=0 link=no multicast=yes wireless=IEEE 802.11
       resources: irq:128 memory:d1000000-d1001fff

sudo ifconfig wlp3s0 up

SIOCSIFFLAGS: Operation not possible due to RF-kill

I am aware that another user experienced a similar problem, whereby the solution was to download drivers - or at least, that's what I understood.

I can see the wifi tab but it won't allow me to activate it, the same applies for the bluetooth. I believe it's the wireless card.

The wifi does work on windows (dualboot). It's an intel card but I'm not sure of anything further.

How do I figure out what the drivers are called / referred to and how do I go about installing them? If there's another solution I'd greatly appreciate it!

Thank you kindly in advance!

UPDATE: I have added in a screen shot of the wireless tab. I can toggle the button on this screen but not from the home screen.

enter image description here

  • Dude you are using the Linux kernel, so forget about drivers it's all built-in, from what I'm Reading with this output you disabled the Wireless card by pressing some F5 key or whatever, if that's not the case, try this command sudo iw dev wlp3s0 connect "wifi_name" and put the password – Egon Stetmann. Jun 16 '17 at 10:18
  • Thanks @RenatoA., unfortunately this did not resolve my problem. The flightmode key is the only key that toggles the wifi slider on/off but no connections are made. The bluetooth won't connect either (even though the slider on the home screen can be toggled on/off). Inputting your code resulted in the following output: – SousaZA Jun 16 '17 at 14:17
  • sudo iw dev wlp3s0 connect The WiFi Usage: iw [options] dev <devname> connect [-w] <SSID> [<freq in MHz>] [<bssid>] [key 0:abcde d:1:6162636465] Join the network with the given SSID (and frequency, BSSID). With -w, wait for the connect to finish or fail. Options: --debug enable netlink debugging – SousaZA Jun 16 '17 at 14:17
1

We blacklisted ideapad_laptop in /etc/modprobe.d/blacklist.conf and it worked. Kinda just kept throwing stones at the OS until something happened but the logic was that lenovo's drivers were layered between the OS and hardware interface (as far as I understand it), thus we removed them.

The laptop is functionally perfectly now - loving this OS!

SIDE NOTE : I was told by a friend who had a similar issue that he had to reinstall Elementary OS and change some secure boot settings - but this was not attempted.

Thanks @Renato A. for the input! You were right about all drivers being present.

  • glad to see that you managed to fix your issue, please mark this thread as solved – Egon Stetmann. Jun 20 '17 at 7:47
  • @RenatoA. We don't mark as solved here, it is preferred that a working solution is accepted SousaZA blacklisting ideapad_laptop might cause some of the FN combos to quit working. I would file a bug report with EOS and see if they can get the problem fixed upstream in the kernel as your model can be included in the quirks list in the ideapad_laptop source code for the rfkill issue – Jeremy31 Jun 28 '17 at 21:01

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.