2

I have this problem on multiple, very different systems.

Running: System Settings>Power>"Sleep when inactive after:" Changing from default of "Never" to any value, backing out, restarting logging in and letting system idle doesn't result in a sleep event.

I can manually put the system to sleep and wake it up just fine.

I see in /etc/systemd/logind.conf

#IdleAction=ignore
#IdleActionSec=30min

As the default, regardless of what I set in the power control panel.

Otherwise on battery the systems in question will sleep on their own with an idle time set in the system's built in power control panel.

Is this a bug, are others having this issue??

2

My work around, or un-elegant fix is thus.

Uncommenting both lines in logind.conf and changing IdleAction=ignore -to- #IdleAction=sleep, setting IdleActionSec=30min to whatever time I desire, I did =5min, then restarting, logging in and waiting the specified time to idle results in the system going to sleep on its own.

It would appear that when the systems are plugged in, or in the case of the desktop always such, the power control panel is useless for this setting as it is simply ignored.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.