3

I am experiencing a weird bug: Some UI elements in setting dialogues (e.g. Scratch, Bluetooth, Startup Applications, Date & Time) are not visible when the respective window opens. As soon as I hover with the mouse pointer they appear, although not all of them apparently.

I recorded a screen-cast reproducing the issue.

This happens with both Intel and nvida graphics. The problem originally showed in freya-0.3.0 but is still present after a fresh install of freya-0.3.1.

Has anyone experienced this problem (or similar) and/or knows a solution? I already filed a bug report some months ago but didn't get any official response...

  • Yes, I experience it as well on my new Dell Precision 5510 (Nvidia Quadro M1000M) using the proprietary nvidia-352 driver v.352.63 I don't have a solution, but this is it how it looks for me: youtu.be/juxQ_RgQDcg As noted, it doesn't occur with (eg) the HighContrast GTK+ theme, and since I only have the default elementary theme and the HighContrast theme installed, I can't comment on whether it's an issue with the default GTK+ theme only. – rambolino Jan 11 '16 at 20:13
2

This is not a proper solution, just a work around so that setting dialogues work (I have the same issue). This only seems to happen with the default elementary GTK+ theme. If you switch to another theme (HighContrast is also installed by default) then the issue is gone for me. Alternatively using the default theme, but then switching to dark also works for me (that's what I use now). Forcing a re-install of elementary-theme (sudo apt-get install --reinstall elementary-theme) does not solve the issue.

The best way to change the GTK+ theme is using gsettings. To switch to a different GTK+ theme open a terminal and run:

gsettings set org.gnome.desktop.interface gtk-theme "HighContrast"

Replace "HighContrast" with the name of theme you want to use. The default theme is called "elementary" if you want to switch back.

To switch to dark edit ~/.config/gtk-3.0/settings.ini in a text editor. For instance open a terminal and run:

nano ~/.config/gtk-3.0/settings.ini

This opens the file in nano. Replace gtk-application-prefer-dark-theme=0 with gtk-application-prefer-dark-theme=1 . Save, close the file (Ctrl + O, Enter, Ctrl + X) and log off and on for the change to take effect. If the file does not exist then create it with the following content (for dark theme):

[Settings]
gtk-application-prefer-dark-theme=1
  • I suggest you use gsettings (it's installed by default and is maintained) as opposed to elementary-tweaks, which works, but is not maintained and not a part of the standard installation. Mentioning it in answers has been discouraged previously by the developers of elementary OS, so don't be surprised if you get downvotes or negative comments for mentioning it. – RolandiXor Nov 8 '15 at 1:35
  • 1
    @RolandiXor: thanks, I've switched to gsettings and updating settings.ini to achieve this without elementary-tweaks. – Plymp Nov 10 '15 at 16:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.