0

I use a program called OpenSCAD to do 3D modelling. It saves its files as filename.scad

So now I want and .scad file to open with OpenSCAD, so: Right-Click, select Open With, select Other Application, and make sure the "Set as Default" box is checked.

Great. That works.

Later, I find that opening any .txt file opens it in OpenSCAD.

Weird. So I re-associate .txt files with notepad and check "Set as Default".

Now all my OpenSCAD files are opening in notepad.

It should be pointed out that OpenSCAD files are just text files.

So, how do I go about associating an application with a particular file extension instead of a file type, as it appears to be doing?

1
  • Linux doesn't care about file extensions, unlike Windows. Linux cares about the file types, usually via the 'magic bytes'. The OpenSCAD files might identify as plain text files, creating this conflict. (They may actually be plain text files that store the data the application uses, try opening one with a plain text editor.) So, if this is the case, your best bet is probably to restore the settings and then use the right click 'open with' method to open your .scad files with the right application.
    – KGIII
    Mar 19, 2021 at 8:52

1 Answer 1

0

Thanks for the explanation. It sounds like something any Linux OS could add as a feature; Autmatic Extension Override wherein the OS opens a user-specified application for user-specified file types in order to avoid these conflicts.

And, yes, OpenSCAD files are just generic text files.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.