2

This has been annoying me a lot recently. Is there a way to disable the "Run" context menu for some specific mimetypes to make it always "Open with <insert default application here>?" For some reason it's not remembering my default application for Lua files. No matter how many times I hit "Open with" and keep the "Keep as default" option checked, I have to repeat the same thing every time. I don't want to run it, I want to open it!

Blank open with submenu

I looked up some stuff and tried editing the mimetype section in the applications desktop entry, but that seems to have no effect. I would appreciate if anyone knows how to change this. By the way, I'm using sublime-text-3 if that matters at all.

3

Using scratch-text-editor to write a simple lua script, these are seen as text files. When marked as "executable" I get the "Run" option, but the "Open With" menu offers text editors. If you do not want to run these files then I suggest you try changing the Properties to remove the "execute" permission. This will stop the "Run" option appearing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.