0

I can't get right mouse click on my touchpad no matter what i do. I have used ElementaryOS before and have had to go to the touchpad prefs and selected "Hardware Default" This used to work, no longer. No matter what I try the right click acts like the left click. I can't get a context menu to come up at all anymore. Like I said. I used to just change the setting to "Hardware Default" and then I had a right click button and a left click. No everything is s left click... this is driving me nuts. I don't like using the "Press and Hold" for secondary mouse click. I have a perfectly good and working right button. You changed the prefs app and now no more right click.

  • So, I've done some more testing. here is what happend. 1. I did a clean install of ElementaryOS 2. I ran all updates. 3. I changed the tackpad press to "Hardware" Nothing happened. It seems like none of the settings on that drop down do anything. 4. Clean install again. 5. When to touchpad prefs changed to "hardware" 6. Tested and it worked as expected. 7. Ran updates. 8. Tested again..still worked. I am afraid to ,ess with the prefs again. But it seems that this part of the prefs isn't working correctly. – David Ferguson Dec 1 at 21:54
0

I used to have the same problem with this laptop (not a huge fan of touchpad anyway), so much so that I ended buying a mouse. But recently I discovered that if I touch the pad very very lightly with two fingers (before the two fingers-touch had not worked either) BUT delay a tiny bit longer than a regular left click, when I release the pad the right click will be taken. I discovered it accidentaly, while playing gnonogram while recharging the mouse batteries. I am not sure whether this is the way it always work for every app (just I didn't know it) or it works just on that game, but I'm assuming the first is the case.

  • I added a new comment.. There is something defiantly wrong with this new prefs thing. – David Ferguson Dec 1 at 22:02
  • what new prefs thing? Did you try the slower two-fingers touch? – Joy Dec 1 at 22:03
  • they made changes to the mouse/touchpad system prefs applet. If I make the change I need before I update the system it's k. After I update and try to use the new prefs applet some things won't work anymore. – David Ferguson Dec 2 at 0:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.