0

I am having an issue with my ASUS F556U laptop touchpad - changes I make in touchpad settings have no effect, I cannot turn tap-to-click off and scrolling doesn't work, no matter what I do. So I have tried playing with xipunt. xinput list returns:

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ FTE1001:00 0B05:0101                      id=11   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ USB Camera                                id=10   [slave  keyboard (3)]
    ↳ Asus WMI hotkeys                          id=12   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=13   [slave  keyboard (3)]

To me it seems that FTE1001... is my touchpad, so I tried using xinput list-props 11 to get available settings:

Device 'FTE1001:00 0B05:0101':
    Device Enabled (139):   1
    Coordinate Transformation Matrix (141): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    libinput Accel Speed (276): 0.000000
    libinput Accel Speed Default (277): 0.000000
    libinput Accel Profiles Available (278):    1, 1
    libinput Accel Profile Enabled (279):   1, 0
    libinput Accel Profile Enabled Default (280):   1, 0
    libinput Natural Scrolling Enabled (281):   0
    libinput Natural Scrolling Enabled Default (282):   0
    libinput Send Events Modes Available (260): 1, 0
    libinput Send Events Mode Enabled (261):    0, 0
    libinput Send Events Mode Enabled Default (262):    0, 0
    libinput Left Handed Enabled (283): 0
    libinput Left Handed Enabled Default (284): 0
    libinput Scroll Methods Available (285):    0, 0, 1
    libinput Scroll Method Enabled (286):   0, 0, 0
    libinput Scroll Method Enabled Default (287):   0, 0, 0
    libinput Button Scrolling Button (288): 0
    libinput Button Scrolling Button Default (289): 0
    Device Node (263):  "/dev/input/event12"
    Device Product ID (264):    2821, 257
    libinput Drag Lock Buttons (290):   <no items>
    libinput Horizonal Scroll Enabled (265):    1

I have tried setting Scroll Methods Enabled to 0,0,1 too, it had no effect on scrolling (though I'm unsure about which value being what method).

What I would like is to turn tap-to-click off and get the scrolling working, but I don't know what to do next.

0

As the code is in 1s and 0s 1 means activated and 0 means deactivated

You need to activate natural schrolling and scroll methods and button scrolling button.

the command to turn off your touchpad in terminal is the following

xinput set-prop "SynPS/2 Synaptics TouchPad" "Device Enabled" 0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.