1

I am using Kdenlive video editor but all my .kdenlive files are shown in Pantheon files with a blank icon. Googling arround and messing with the hicolor icon theme I have some results only if I change the default icon set via ElementaryTweaks to any different then 'elementary'. If I do this no matter that a lot elementary os specific icons are missing, all .kdenlive and .kdenlivetitle files has the corresponding mime type icons. If I revert back to the "elementary" icon theme - again they became blank.. It works like this even if I add corresponding icons application-x-kdenlive.png/.svg into elementary icon theme folder also.

in order to rebuild icon/mime caches I use

sudo update-icon-caches /usr/share/icons/*
sudo update-desktop-database
sudo update-mime-database /usr/share/mime/
gtk-update-icon-cache

The mime format is ok, because if I drag a .kdenlive file on the plank, it uses the appropriate icon also, but in Pantheon files the icon remains blank(white rectangle) no matter what I try to do.

Any idea how can I fix this?

  • 1
    These seems to affect some other Gtk file managers as well and is related to the way Gtk searches the elementary icon directory, which is laid out differently to other icon themes. When I changed Files code to force it to search the hicolor theme before using the generic icon and put the the custom application icon there it worked OK. Using the Dolphin filemanager also worked (not sure whether it was finding the icon in the elementary or hicolor theme. I was experimenting with a different custom app icon - not kdenlive - which has the same issue. – Jeremy Wootten May 25 at 10:42
  • 1
    Try gtk-update-icon-cache --force /usr/share/icons/elementary – Jeremy Wootten May 25 at 11:55
  • 1
    Using ` gtk-update-icon-cache --force /usr/share/icons/elementary` fixed a similar issue for me. Make sure you use the --force option. – Jeremy Wootten May 27 at 17:54
  • Yes, It works. Thanks a lot. Can you share it like an answer of the question so I can mark it the correct one? – Bo rislav May 28 at 7:28
2

Using gtk-update-icon-cache --force /usr/share/icons/elementary fixed a similar issue for me. Make sure you use the --force option.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.