1

I tried changing the background wallpaper in greeter following the top answer from this question: How do I change login background in elementary OS Freya or Loki?

I first changed the pantheon-greeter.conf to use a .jpg file which I also copied into /usr/share/backgrounds instead of the elementaryos-default option.

So I changed

#default-wallpaper=/usr/share/backgrounds/elementaryos-default

into

#default-wallpaper=/usr/share/backgrounds/winter.jpg

But after reading further on the tutorial, which said not to mess with the defaults, I decided to change it back to keep the default option and instead I opened Files as sudo and edited the permissions of the copied file in /usr/share/backgrounds from 775 to 664. I thought this would have just allowed me to access the newly copied file through the system settings.

However, this did not work and instead my wallpaper and my logon screen both showed up as black now and when opening Settings, when trying to edit the settings for the Desktop and selecting "Backgrounds" in the menu on the bottom left, no pictures are displayed at all (all is blank). Missing Wallpapers Moreover, when navigating to /usr/share/backgrounds as a regular user, all files are now shown as missing (clicking them returns "file does not exist") with permissions in their properties set to 000 and filesize of o Bytes. enter image description here When opening up pantheon-files as sudo, however, all files display correctly with thumbnails and can be opened also. As permissions, they display 664 then.

I managed to get my wallpaper back by copying all wallpapers from /usr/share/backgrounds/ to ~/Pictures/ and then selecting Pictures as the source for my background in Settings, which also changed elementary os screenshotsmy greeter background, but I still want to get my Default backgrounds folder to work again.

Anyone have an idea as to why the files are not inaccessible for my normal user and how to fix it? Any help is greatly appreciated.

2

Your have problem with permission, could you please output ls -ld /usr/share/backgrounds and ls -l /usr/share/backgrounds/ ?

Directory backgrounds should be 755

drwxr-xr-x 2 root root 4096 Nov  4 03:22 /usr/share/backgrounds

and files should 644

-rw-r--r-- 1 root root  498830 Okt  5 05:16 164.jpg
-rw-r--r-- 1 root root  633430 Okt  5 05:16 168.jpg
-rw-r--r-- 1 root root  397147 Okt  5 05:16 16.jpg
-rw-r--r-- 1 root root  480634 Okt  5 05:16 173.jpg

try this

sudo chmod -R 644 /usr/share/backgrounds
sudo chmod 755 /usr/share/backgrounds

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.