0

After performing a fresh install of Loki 0.4.1 on my White Macbook 2010, which worked perfectly, I proceeded to update the system from within the App Center itself. When I rebooted, after entering my disk password (it's encrypted), I got stuck on a black screen with the mouse pointer. I can move it and press enter (which sometimes hides the cursor, but ends up showing it again). I can also open a tty (but it closes itself from time to time to show again the black screen with the pointer, almost like if I were stuck on a loop).

I have tried several things after this:

  • Download and install elementaryOS 5.0 Beta 2. Black Screen.
  • Download and install elementary0S 0.4.1 Works fine.
  • Upgrade a fresh 0.4.1 install. Stops working and black screen appears again.

I have no idea of what to do now, so I would really appreciate if someone could walk me through.

0

Ok, I found the answer.

  1. Once eOS is installed and booted (stuck on the black screen), Open a tty (find a way to access your command line, like ctrl+alt+fn+F1 on a Mac) and login.
  2. sudo nano /etc/default/grub
  3. Add the parameter nouveau.modeset=0 at the end of GRUB_CMDLINE_LINUX_DEFAULT="".
  4. Save (ctrl+x), run sudo update-grub, and reboot.

Now it works (not sure what are the implications of setting nouveau.modeset=0 performance wise, if any)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.