0

I would greatly appreciate help or advice on the following issue \ as I am totally stuck. I have been using Linux for a long time but I am a biologist. So deep down my knowledge on how works a computer is limited. I will try to describe as well as possible the problem. Looks to me this is not a new problem but when I tried solutions seen in various posts I had no luck

Two months ago I installed elementary OS (Loki) on the old MacBookPro (2008) of my wife. No double boot option. Just elementary OS. On the install, everything went super smooth. My wife was super happy, as the computer now worked very well and was faster than using the latest MacOS. Occasionally she mentioned that the computer took very long to wake up from the sleep mode (when she closed the computer screen). Two days ago she calls me at work saying that the computer did not wake from sleep and that after restarting (by pressing 5 sec on the power button), there is a new screen coming up and then black screen. Indeed when I come home I see that upon restart, a GNU Grup window (version 2.02) with a choice between elementary or Advanced option for elementary. This is new indeed as usually, after starting the computer, elementary starts directly. And yes if I hit enter on elementary the screens turn black and nothing happens even if we wait for hours (I did try that). I restarted the computer and tried my chance using the advanced options. There I have to choose between two versions (4.4.0-63-generic or 4.4.0-62-generic) of eOS with additional options (upstart or recovery mode). I tried all the options with no luck. If I hit recovery mode there are a bunch of lines that comes up but computer freezes quickly (1.3456 s) at a line that says ehci-pci 0000:00:04.1: irq 22, io mem 0xdf489200.

After doing some search on the internet I tried the following: (but nothing worked so far)

1) Start eOS and modify boot option and add acpi=off. This got me very close to success. elementary started just fine (I could see the entire desktop) but the touchpad and keyboard were totally unresponsive. It looked like wifi had a problem too. I tried to plug a usb mice but no success. Today I will bring back from work a keyboard but I doubt this will work.

2) start eOS in recovery mode with acpi=off. This got me to an old fashion looking windows and on a pink background with a bunch of interesting options like resume, clean, dpkg, fcsk, grup (update gup loader) … but there is nothing I can do as my keyboard was not reactive anymore at this stage

3) Start eOS and modify boot option and add nomodeset instead of quiet psalsh: black screen. I tried a few other things I forgot without success

4) if I go into the grub command line menu (by typing c) and typed “ls” I see a list of partitions but at the end it says (cd0) error:failure reading sector 0x0 from 'cd0'. If I explore the partitions using ls I can see my wife's data so this is good (of course, she did not back up her most recent work, despite having dropbox installed ….)

5) I found a post that suggest to use the grup command line and the option configfile (hd0, gpt4)/boot/grub/grub.cfg. But upon reboot still black screen

6) I plugged the install USB drive and press the option key after rebooting. Then if I click on an icon that says EFI boot, I can see very briefly a short error message but I could not read it. Then I go back to a grub menu with 4 options: Try eOS without installing, Install eOS, OEM install or check for disc defects. Nothing worked just black screen when I hit enter.

So basically I am stuck. I have two main concerns. My wife needs some data not backed-up. I am worried I can not start eOS from the USB drive. I know this looks like previous similar questions but I could not manage to fix my computer using other posts. I am not far but need a bit of help

Thanks a lot for your help

0

As no help came, I researched more on others solutions and managed to fix my problem !!!!.

I adapted this solution to my case (small differences between boot files between freya and loki)
In fact what I had to do was to enter the Grub command line (c) and typed:

  1. configfile (hd0, gpt1)/efi/ubuntu/grub.cfg [instead of (hd0, gpt1)/boot/grub/grub.cfg, as suggested in the post].
  2. then hit F10 I booted elementary from the grub menu.

NO more black screen that time (I could see the elementary logo). But then I had a flashing cursor for ever. I forced reboot and elementary started correctly that time, no more grub menu. It went straight to the desktop ...

Then I followed/modified the rest of the instructions (Even if I am not sure this was necessary)

  1. sudo cp /boot/efi/EFI/ubuntu/grubx64.efi /boot/efi/EFI/ubuntugrubx64.efibackup
  2. sudo rm /boot/efi/EFI/ubuntugrubx64.efi
  3. sudo cp /boot/grub/x86_64-efi/grub.efi /boot/efi/EFI/ubuntu/grubx64.efi

I restarted my computer (twice) and no issue.

Of course, the big question I have is what the f... happened in the first palce?!!! The computer was working fine for two months and my wife did not install anything ...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.