1

I have elementary OS Freya installed on a 2009 MacBook Pro. After the initial install and update/upgrade last night, elementary worked great for the 6 hours I was using the laptop. When finished I closed the lid which put the laptop to sleep. I noticed in class today, when I opened the macbook it allowed me to click my wireless network on campus, but then locked up/froze while connecting to the network. After about 40 seconds, the splash screen to log in pops up. I can log in and at that point I was connected to the wireless network, but all my previously opened applications where shutdown and when I re-opened them, they needed recovering. I used the laptop like normal for another hour.

I finished my work and closed my lid, once again putting the laptop to sleep. In my next class I opened my laptop and proceeded to click Libre Office Writer, it partially opened then locked up/froze. After 45 seconds or so, the splash screen re-appeared and I was able to log in. Once again, all applications previously opened were closed and needed recovering when opening files.

I have a feeling this has to do with sleep? I have also noticed my laptop runs considerably hotter than using Mac OS X. I have installed tlp and have it enabled, I also have powertop installed. I'm currently using open source graphics--I have NEVER been successful in getting nvidia mac graphics working (always black screen afterwards, regardless of which distro or nvidia number driver I try.)

Any advice on what might be causing the freezing and how I can fix this issue?

1

I think I may have found a solution to my problem, so I wanted to post the solution here in case anyone else is having the same freezing issues.

I found a similar post I made on a Deb forum over a year ago and the solution was given to me by user kc1di:

Try the nouveau.noaccel=1 parameter - hit tab at the boot command and the e type in:

nouveau.noaccel=1

after the kernel line that has quiet in it.

If that works for you you can make it permanent by editing the /etc/default/grub file. and making it look like this:

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet nouveau.noaccel=1"
GRUB_CMDLINE_LINUX=""

I tried this with elementary OS and all seems well. The graphics when an application opens aren't as smooth/clean looking as before, but I've put my computer to sleep, woken it up, opened various apps many times now and it never seems to freeze anymore. So far so good!

  • Don't forget to mark your own answer as the solution :) – Daniel Foré Oct 5 '15 at 18:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.