0

I use a nightly version of Thunderbird. Which means I have to use my own Desktop file if I want it to work properly (and not mess up everything).

It currently looks like this:

[Desktop Entry]
Version=1.0
Name=Thunderbird Daily
GenericName=Mail Client
Comment=Mails, Calendars and Chat
TryExec=thunderbird
Exec=thunderbird --class=Daily %U
Icon=thunderbird
Type=Application
Categories=GNOME;GTK;Network;Email;
Keywords=GPG;PGP;XMPP;Jabber;Task;Todo;IMAP;POP;SMTP;Newsgroup;E-Mail;Mail;
MimeType=text/plain;text/eml;text/calendar;application/rss+xml;x-scheme-handler/mailto;x-scheme-handler/irc;x-scheme-handler/xmpp;x-scheme-handler/webcal;message/rfc822;x-scheme-handler/news;x-scheme-handler/snews;x-scheme-handler/nntp;x-scheme-handler/feed;
StartupNotify=true
StartupWMClass=Daily
Terminal=false
X-GNOME-UsesNotifications=true
X-MultipleArgs=false

It used to have a lot more categories and I also tried just specifying x-scheme-handler/mailto like pantheon mail does, to no avail.

The desktop file is in my .local/share/applications folder, where I have other desktop files. I can select Thunderbird Daily as my default Calendar application. Or even text editor, should maybe remove that text/plain...

Further, desktop-file-validate has no issues with it.

Yet I can not select Thunderbird Daily as my default mail application, only pantheon mail is available.

I'm on 0.4.1 Loki with the settings app at version 2.3.0

0

Manually forcing an update (i.e. editing) mimeinfo.cache and mimeapps.list in ~/.local/share/applications solved this.

The proper way to do it would be to execute update-mime-database.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.