1

I installed elementary OS on my laptop(14-inch,1080p). and the icon and text are just too small, smaller than Win10.

Textsize in the settings only effects on the preinstalled applications.

I've tried setting scale-factor in the terminal, but it only let me set either 1 or 2(200%), I want to scale around 125%~150%, how can I do this?

  • I think I found the solution to your issue here: askubuntu.com/questions/379123/… – Pretzel Jones Mar 10 '18 at 1:47
  • Thanks, I tried it, but xrandr --output LVDS1 --scale 0.8x0.8 looks like it just reduce the resolution of my monitor. – Ives Mar 10 '18 at 3:34
  • Maybe try going on the other direction, possibly 1.25x1.25 – Pretzel Jones Mar 10 '18 at 12:26
  • 1.25x1.25 makes everything looks smaller.(1920x1.25, 1080x1.25 dpi is higher) – Ives Mar 10 '18 at 15:12
  • I think it's doing what you want then. 0.8 should make everything in the screen bigger just as it would if the screen resolution was lower. – Pretzel Jones Mar 11 '18 at 6:34
5

I think what you may be looking for can be done by using dconf-editor. If you do not have it installed, you can do so in Terminal with this:

sudo apt install dconf-editor

Once installed, open dconf-editor and in the left pane navigate to org> gnome> desktop> interface then look for 'text-scaling-factor' in the right pane. The default is, of course, set to 1.0. You can put in 1.25 or 1.50 then hit tab and the change will take effect immediately. You can also search with the editor for other scaling options, too. One word of caution...be very careful using dconf-editor as many a desktop has been botched in one way or the other using the tool.

Hope this helps and Good Luck!!!

EDIT: I just saw Sean's comment to your question and that may be closer to what you're looking for...

  • Cool! "text-scaling-factor" works fine in the apps I've installed, although I don't have done a lot. – Ives Mar 10 '18 at 3:30
  • btw, I found I can disable single-click to open file by dconf-editor, powerful app! – Ives Mar 10 '18 at 3:32
  • Awesome! Like I said, there are other scaling options within dconf-editor if you search for them. The search is on the right corner of the window...kinda looks like an 'X'. Just be careful with changes. – linux_tim Mar 10 '18 at 3:32
  • This also works for elemantry OS Juno thanks – Aftab Naveed Oct 20 '18 at 7:21
  • Installed Elementary OS 5. Unable to see the fractional scaling. only int scaling is allowed. How to enable that? imgur.com/yCD9YRW – Mrinal Bhattacharjee Nov 11 at 23:54

Not the answer you're looking for? Browse other questions tagged or ask your own question.