Okay, this is almost fresh install, installed about week ago. Today I started to write my essay with Libreoffice and found that this computer freezes about every 20 min when using Libreoffice. Screen is halted about 20 seconds and then it drops to login screen.

I looked into kern.log and found this:

Jan 18 23:09:47 envy kernel: [  742.192714] [drm] GPU HANG: ecode 9:0:0x85dffffb, in Xorg [1039], reason: Hang on rcs0, action: reset
Jan 18 23:09:47 envy kernel: [  742.192744] drm/i915: Resetting chip after gpu hang
Jan 18 23:09:47 envy kernel: [  742.192812] [drm] RC6 on
Jan 18 23:09:55 envy kernel: [  750.181140] drm/i915: Resetting chip after gpu hang
Jan 18 23:09:55 envy kernel: [  750.181283] [drm] RC6 on
Jan 18 23:10:03 envy kernel: [  758.180982] drm/i915: Resetting chip after gpu hang
Jan 18 23:10:03 envy kernel: [  758.181150] [drm] RC6 on
Jan 18 23:10:11 envy kernel: [  766.180827] drm/i915: Resetting chip after gpu hang
Jan 18 23:10:11 envy kernel: [  766.181004] [drm] RC6 on
Jan 18 23:10:19 envy kernel: [  774.180669] drm/i915: Resetting chip after gpu hang
Jan 18 23:10:19 envy kernel: [  774.180841] [drm] RC6 on
Jan 18 23:10:30 envy gnome-session-binary[2809]: Entering running state

Laptop is HP Envy 13-d004no, Intel based hardware mainly, i5 CPU.. etc. Nothing special, just Elementary OS installed, Google Chrome and Mega Sync repo added. System updated today.

Is this related to this ongoing Intel bug? Because this is found from kenr.log, I don't think that this is Elementary bug.

Anyway, this is critical, because my laptop is unusable now. It's annoying when you lost your work because your WM hangs. :/

  • Try sudo apt update and sudo apt upgrade and sudo reboot to see if there is any change, or is everything up to date?
    – AsymLabs
    Commented Jan 18, 2018 at 22:52
  • I've not experienced this issue with Kernel 4.13.0-26-generic, Loki 0.4.1 and LibreOffice on an older i3 laptop. You can change some settings in LO5 - see menu Tools > Options > Advanced (turn Java off/on) and Tools > Options > OpenCL (software/hardware settings and whitelists).
    – AsymLabs
    Commented Jan 19, 2018 at 4:46

2 Answers 2


This also happens on AMD desktops too. I cannot seem to pinpoint it, and it is rather annoying. I don't really have a solution, but try adding these repos to keep up to date with your software.

sudo add-apt-repository ppa:libreoffice/libreoffice-5-3

sudo add-apt-repository ppa:ubuntu-x-swat/updates

Those will keep LibreOffice Stable and you video drivers up to date. If the problem continues, try using your computer with your previous kernel. I had to lock mine at 4.11.12 last week as the update made my system unusable.

  • 1
    Why LO 5-3? Loki 0.4.1 on an older Dell i3 laptop is newly installed and fully upgraded with Kernel 4.13.0-26 LO and is operating flawlessly - maybe LO 5-3 should not be used? The OP's error messages point to the gpu/drm; could be OpenCL in LO 5-3 that is causing the problem.
    – AsymLabs
    Commented Jan 19, 2018 at 19:49
  • I use the LibreOffice 5.3 PPA because it is the latest stable build. With this fix the goal is to upgrade LibreOffice to the latest stable build and to add a PPA for more up to date graphics drivers. Hopefully the combination will lend a fix.
    – Eosdude
    Commented Jan 19, 2018 at 20:23

I've found something interesting that may be related to your issue:

Baytrail complete freeze

If you are using kernel > 3.16 on Baytrail architecture and randomly encounter total system freezes, the following kernel option is a workaround until this bug is fixed in the linux kernel.


This is originally an Intel CPU bug that can be triggered by certain c-state transitions. It can also happen with Linux kernel 3.16 or Windows, though apparently much more rarely. The kernel option will prevent the freeze by avoiding c-state transitions but will also increase power consumption.

To add that line as a kernel option you need to edit /etc/default/grub and add it to the list of options inside GRUB_CMDLINE_LINUX_DEFAULT=" ". Then save that file and execute sudo update-grub from terminal. Reboot and it should be fixed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.