when I restart or suspend my machine I suddenly cannot connect to my wifi network, what I read on other posts is to use this line code:

sudo killall NetworkManager

This help when I'm just using my wireless network, but when I'm with the cable the network icon change and try to find the cable network.

  • I guess this is hardware specific issue. It doesn't occur on my mbp. So, it would be helpful if you include your pc specs.
    – ounos
    Aug 19, 2015 at 8:40

2 Answers 2


I will have to investigate further to find an automatic solution, but this problem occasionally happens to me as well.

The solution I use is to run

sudo restart NetworkManager

This restarts network manager cleanly and re-establishes any connections you had.

There was a bug in older Ubuntu systems where this would occur and you had to add a command to one of the files uses by pm-utils, but it seems this problem is not exactly the same as the previous one.


This seems a rather frequent problem even in Loki and ubuntu 16.04: 16.04 LTS wifi connection issues and it happened very often on my system.

After following this answer it got less frequent I guess.

What it says is:

  1. Get details of your PCI wireless card by running sudo lshw -class network
  2. Get your card model info according to the product line. For instance, as you can see in the question description it says product: RTL8723BE PCIe Wireless Network Adapter so the model of my card is RTL8723BE
  3. Open or create /etc/pm/config.d/config and add SUSPEND_MODULES="rtl8723be"(replace rtl8723be with your own model number) Then run echo "options rtl8723be fwlps=N" | sudo tee /etc/modprobe.d/rtl8723be.conf and reboot.

It rarely happens now and when it does I use the command service network-manager restart.

That can be associated with a shortcut key. I prefer a desktop launcher to run from Slingshot:

gedit ~/.local/share/applications/restart_wifi.desktop


[Desktop Entry]
Name=Restart Wifi
Exec=bash -c 'service network-manager restart'

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.