0

Wireless network (wifi) not detected on Dell Vostro running Elementary OS Jolnir 6.1. It used to be able to detect the wifi before. The wireless network simply no longer shows up in networks

screenshot of Only Wired device detected

But it used to detect the wireless network before and I was able to use wifi and I had some wifi connection saved by running nmcli con show:

screenshot of nmcli con show

The Wireless Network adapter shows up when I run sudo lshw -c network, but the status is *-network UNCLAIMED

screenshot of sudo lshw -c network

There is a page in Dell Support that suggests reinstalling the wifi driver but I cannot find the driver to download anywhere. Already tried rebooting the device to no avail.

1 Answer 1

0

This is an issue directly with the Wireless Card, I had the same issue and it was happening either Windows or EOS and I had to restart the laptop multiple time to get it work so I came across with some forums post saying that the problem is the card itself and not a driver issue, I would suggest to get a WiFi card replacement and use an Intel instead because those RealTek models kind of suck. I had RT8822CE and the same behavior.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.