3

I have a lenovo b50, recently installed elementary os.

While the wifi is theoretically working at times, it keeps fooling around after coming back from sleep mode. What it does is, that it suddenly cannot detect any wifi connections, unless I type my network name into "find hidden network".

output of sudo lshw -C network is: *-network
description: Ethernet interface product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller vendor: Realtek Semiconductor Co., Ltd. physical id: 0 bus info: pci@0000:08:00.0 logical name: enp8s0 version: 10 serial: f0:76:1c:1f:6c:25 size: 10Mbit/s capacity: 1Gbit/s width: 64 bits clock: 33MHz capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8168g-3_0.0.1 04/23/13 latency=0 link=no multicast=yes port=MII speed=10Mbit/s resources: irq:47 ioport:4000(size=256) memory:c2604000-c2604fff memory:c2600000-c2603fff *-network description: Wireless interface product: Wireless 3160 vendor: Intel Corporation physical id: 0 bus info: pci@0000:09:00.0 logical name: wlp9s0 version: 93 serial: d0:7e:35:2d:40:bf width: 64 bits clock: 33MHz capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless configuration: broadcast=yes driver=iwlwifi driverversion=4.4.0-57-generic firmware=17.352738.0 ip=10.0.0.2 latency=0 link=yes multicast=yes wireless=IEEE 802.11abgn resources: irq:52 memory:c2500000-c2501fff

  • What's the output of "sudo lshw -C network"? – bitseater Jan 4 '17 at 21:43
  • i added it to the op – user8000 Jan 5 '17 at 8:26
  • What is the output for cat /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf – Jeremy31 Jan 7 '17 at 18:56
  • askubuntu.com/a/768268/47206 – user170 Jan 23 '17 at 13:26
0

This is a known issue with Intel 3160 driver. You can install a forked driver to prevent power saving error after coming up from sleep mode.

I have installed it on my Lenovo G50-80 with the same wifi card. Download and untar the new driver from:

Bitseater's dropbox

in your home folder. Now open a terminal into the new folder and type:

sudo apt-get install linux-headers-$(uname -r)
cp /usr/src/linux-headers-$(uname -r)/Module.symvers Module.symvers
sudo apt-get install build-essential
make -C /lib/modules/$(uname -r)/build M=$(pwd) modules
sudo cp ideapad-laptop.ko /lib/modules/$(uname -r)/kernel/drivers/platform/x86/
sudo rm /etc/modprobe.d/ideapad.conf

I have added a readme file with the instructions. Reboot and try to connect to your SSID.

Updated

To prevent wireless card stop working after coming from sleep mode, open a terminal and type:

echo "options iwlmvm power_scheme=1" | sudo tee /etc/modprobe.d/iwlmvm.conf

Then reboot your system.

0

You can mange options with changing the parameters in /erc/modprobe.d/iwlmvm.conf. To know the avalaibles parameters try from terminal with modinfo iwlmvm. Try too with the parameters of iwlwifi: modinfo iwlwifi

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.