How to get a bluetooth tether to work? I thought it was my old phone, but now I have a new one and it still does not work.

I can create a bluetooth connection to eOS from phone I can create a tether from phone I do not know how to connect

It was working before with ubuntu Mate using another device (no longer in my possession)

Android 6 and Loki

1 Answer 1


From what I understand you are looking to set up a PAN. Ubuntu is preloaded with features while eOS is minimalist. I believe what you are looking for is discussed here on superuser.


UPDATE: As you requested terminal scripts I found a GUI program that manages most all of this for you. It is old, but it works, as I am posting this via the Bluetooth from my iPhone 6s+.

sudo apt-get blueman (this guy uses bluez that we have already)

after installing the program, pair your device using the eOS built in manager: [to be addressed in a moment, upload a pic on strong LTE via bluetooth is painful] [enter image description here]2

dont forget to verify on both the computer and phone. enter image description here configure your phone to allow hotspot and ensure your phone is broadcasting its hotspot via Bluetooth as well.

"super" + "space" will open app tray, type "blue" and you should see "Bluetooth Manager" in your options. Select this. enter image description here

You should now see your paired device, right-click it and select the "Network Access Point" option. enter image description here

eOS should now give you a notification that you are now connected to the internet!

As there was a viable solution I outlined it here, unless other situations inhibit this, using the wifi-hotspot or usb-hotspot on your mobile will give you a faster networking experience. Attempting to upload these screenshots via Bluetooth tether failed a few times while USB tether was near instant.

Thanks for the chance to help and learn a bit more about eOS and Linux!

  • Thanks.. but I have no idea how to get it to work. Not only is it complex, but one user said it was outdated. Can you tell me the Terminal .commands to type. Oct 9, 2017 at 2:55
  • 1
    I was able to find a solution and edited my original post, I hope this solution works for you! Oct 11, 2017 at 7:50
  • Thanks for your work pictures and gui findings. It worked for me. Solved. Btw: You might want to wait just a little bit before you judge the speed. One gripe I have about eOS is that it does an app get update everytime you connect. Therefore, look at your network speed (use gnome sys mon). I get about 80 KBs which is fine. The reason is that bluetooth is more secure and not public. Oct 13, 2017 at 9:21
  • Wow, this is works like a charm! Thank you Kreston Lee! Bluetooth tethering on elementary OS easy as ever.
    – Peter
    Jul 2, 2022 at 9:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.