2

I have Elementary OS Loki installed on my Dell XPS 15, I've got it paired to my UE Boom 2 and Bose QuietControl 30, but they aren't showing up as a possible Sound output.

Their indicated type is Headphones.

I was able to work with them on my old 17" MacBook pro with Elementary Loki.

To get Elementary OS installed I followed the following blog post, which included a bluetooth fix. https://ubuntuforums.org/showthread.php?t=2317843

Update: I think I got it working for my Bose QC... Advised by the following question I installed bluetooth and pulseaudio-module-bluetooth. Maybe that helped. I did need to reboot and re-pair. https://askubuntu.com/questions/689281/pulseaudio-can-not-load-bluetooth-module-15-10-16-04-16-10 Strangely enough I still can't get my UE Boom 2 to work.

Update 2: Seeing that lot's of people switched out the Killer wifi card in the XPS 13 line (in my case the Killer 1535), for the Intel 8265, since intel drivers would work better on Linux I thought I'd tried the same. It didn't went well I'm afraid, I had to upgrade the Kernel from the default 4.4 to +4.6 for it to be recognized. But then the bluetooth connection was disconnected frequently, usually after a few minutes. (I also tried removing tlp and downloading new drivers from https://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/linux-firmware.git but that didn't seem to help.

Update 3: I've upgraded to the latest elementary OS Juno (based on Ubuntu Bionic 18.04) and now everything works! On a fresh installation I can easily pair with my Bose QuietControl 30 and UE Boom 2 and use them as sound output. No extra applications or tweaks required.

  • Check the bug report and see if the a2dp.py script helps connect – Jeremy31 Jan 21 '17 at 17:20
1

Thanks Jeremy31, I tried the a2dp.py script but I was getting the following error: `Cannot find

bluez_card.04_52_C7_1B_7B_BC` using `pactl list cards short`. Retrying 8 more times

After trying a few other suggestions I tried https://askubuntu.com/a/836202/519324. I used the regular Elementary bluetooth discover flow, then I installed Blueman but the Audio Profile didn't have a submenu. Running Setup on my device, selecting Connect to: Handsfree suddenly my device appeared as sound output. So now it sort of works. I still need to restart my bluetooth device frequently to get it to work properly. When I'm home I'll try this with my other bluetooth device, see if that fixes it for that one too.

Update: In regards to my Bose QuietControl 30, I've had to re-pair a couple of times in the mean time and usually I've had to retry the setup part a couple of times before it would suddenly start working again. I don't need to restart my bluetooth device that often anymore. I still need to restart it when it was on before my computers boots, then I need to restart for it to reconnect. And if I walk to far and the audio get's off-sync. I've never been able to get my UE Boom 2 to work.

I've also tried replacing the Atheros Qualcomm Killer with the Intel 8265, which also forced me to upgrade the kernel, but that gave me even more issues. The bluetooth connection would always stop after a few minutes, even after removing tlp.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.