7

I have recently installed Elementary OS, Loki on a Mac Mini (mid 2010).

I successfully configure a bluetooth keyboard and trackpad (both apple) using the 'System Settings::Bluetooth' panel. Pairing works fine.

If I logout and login, the paired keyboard and trackpad continue to work fine.

If I suspend and resume, Bluetooth has been disabled in the bluetooth panel and in wingpanel.

If I reboot, Bluetooth has been disabled in the bluetooth panel and in wingpanel. (same as suspend resume...but I fear root cause may be different).

To recover, I merely re-enable bluetooh and my devices re-pair.

The frustration is that I cannot use a bluetooh keyboard/trackpad which will not wake the computer from sleep or be unavailable after reboot.

1

To enable bluetooth on every startup you need to add your custom command in etc/rc.local

Open terminal and type

sudo nano /etc/rc.local

Now add the following line before exit 0

rfkill unblock bluetooth

It will start bluetooth on every startup.

1

In console:

bluetoothctl

Connect bluetooth device and see in console. Example:

[CHG] Device 00:1F:20:E1:B3:B7 Connected: yes
[CHG] Device 00:1F:20:E1:B3:B7 ServicesResolved: yes

Copy device code. Trust this device:

trust 00:1F:20:E1:B3:B7

This worked for me.

Source https://pctuner.club/n/2415

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.